CVE-2025-53000
High · 7.8CVSS
7.8
EPSS
0.3%
Published
Dec 17, 2025
CISA due date
—
The record
The nbconvert tool, jupyter nbconvert, converts Jupyter notebooks to various other formats via Jinja templates. Versions of nbconvert up to and including 7.16.6 on Windows have a vulnerability in which converting a notebook containing SVG output to a PDF results in unauthorized code execution. Specifically, a third party can create a `inkscape.bat` file that defines a Windows batch script, capable of arbitrary code execution. When a user runs `jupyter nbconvert --to pdf` on a notebook containing SVG output to a PDF on a Windows platform from this directory, the `inkscape.bat` file is run unexpectedly. This issue has been patched in version 7.17.0.
Affected packages
| Ecosystem | Package | Introduced | Fixed |
|---|---|---|---|
| PyPI | nbconvert | 0 | No fix |
| PyPI | nbconvert | 0 | 7.17.0 |
| Chainguard | jupyter-base-notebook | 0 | 0 |
| Chainguard | jupyter-base-notebook-oci-entrypoint | 0 | 0.0.0_git20251220-r0 |
| Chainguard | kubeflow-pipelines-visualization-server | 0 | 0 |
| Chainguard | py3-nbconvert | 0 | 7.16.6-r1 |
| Chainguard | py3-supported-nbconvert | 0 | 7.16.6-r1 |
| Chainguard | py3.10-nbconvert | 0 | 7.17.0-r0 |
| Chainguard | py3.10-nbconvert-bin | 0 | 7.16.6-r1 |
| Chainguard | py3.11-nbconvert | 0 | 7.17.0-r0 |
| Chainguard | py3.11-nbconvert-bin | 0 | 7.16.6-r1 |
| Chainguard | py3.12-nbconvert | 0 | 7.17.0-r0 |
| Chainguard | py3.12-nbconvert-bin | 0 | 7.16.6-r1 |
| Chainguard | py3.13-nbconvert | 0 | 7.17.0-r0 |
| Chainguard | py3.13-nbconvert-bin | 0 | 7.16.6-r1 |
| Chainguard | tensorflow-cpu-jupyter | 0 | 0 |
| Chainguard | tensorflow-gpu-jupyter | 0 | 0 |
| Wolfi | jupyter-base-notebook | 0 | 0 |
| Wolfi | jupyter-base-notebook-oci-entrypoint | 0 | 0.0.0_git20251220-r0 |
| Wolfi | kubeflow-pipelines-visualization-server | 0 | 0 |
| Wolfi | py3-nbconvert | 0 | 7.16.6-r1 |
| Wolfi | py3-supported-nbconvert | 0 | 7.16.6-r1 |
| Wolfi | py3.10-nbconvert | 0 | 7.17.0-r0 |
| Wolfi | py3.10-nbconvert-bin | 0 | 7.16.6-r1 |
| Wolfi | py3.11-nbconvert | 0 | 7.17.0-r0 |
| Wolfi | py3.11-nbconvert-bin | 0 | 7.16.6-r1 |
| Wolfi | py3.12-nbconvert | 0 | 7.17.0-r0 |
| Wolfi | py3.12-nbconvert-bin | 0 | 7.16.6-r1 |
| Wolfi | py3.13-nbconvert | 0 | 7.17.0-r0 |
| Wolfi | py3.13-nbconvert-bin | 0 | 7.16.6-r1 |
| Wolfi | tensorflow-cpu-jupyter | 0 | 0 |
| openSUSE:Tumbleweed | python-nbconvert | 0 | 7.17.1-1.1 |
Related vulnerabilities
- CVE-2026-34073 cryptography is a package designed to expose cryptographic primitives and recipes to… Also affects jupyter-base-notebook
- CVE-2026-25645 Requests is a HTTP library. Also affects jupyter-base-notebook
- CVE-2026-4539 A security flaw has been discovered in pygments up to 2.19.2. Also affects jupyter-base-notebook
- CVE-2026-26007 cryptography is a package designed to expose cryptographic primitives and recipes to… Also affects jupyter-base-notebook
- CVE-2026-21441 Decompression-bomb safeguards bypassed when following HTTP redirects (streaming API) Also affects jupyter-base-notebook
- CVE-2025-50182 urllib3 does not control redirects in browsers and Node.js Also affects jupyter-base-notebook
- CVE-2024-47081 Requests is a HTTP library. Also affects jupyter-base-notebook
- CVE-2025-47287 Tornado vulnerable to excessive logging caused by malformed multipart form data Also affects jupyter-base-notebook