Cloudanix VulnDB

CVE-2025-4948

High · 7.5

CVSS

7.5

EPSS

0.8%

Published

May 19, 2025

CISA due date

—

Cloudanix analysis

Monitor only SSVC: Track

A bug in a common web communication library can let attackers send specially formatted messages that crash applications and take services offline.

Exploitation
Remote Unauthenticated
Attacker needs
None
Complexity
Low
Impact
Denial Of Service
Component
Library
Class
Memory Corruption
Remediation
Upgrade
Effort
Medium
Patch risk
Low

What it actually does

Integer underflow in soup_multipart_new_from_message() when processing specially crafted multipart messages due to improper validation, resulting in invalid memory access and application crash.

Why it matters to the business

Services and applications relying on libsoup on affected Ubuntu systems can be forced offline unexpectedly, disrupting availability and requiring restarts or failover handling.

How an attack unfolds

An attacker crafts a malicious multipart HTTP message and sends it to any network-reachable application or server that uses the vulnerable libsoup library; the malformed input triggers the underflow during parsing, causing the process to crash and resulting in denial of service.

How to fix it

Upgrade affected packages to the fixed versions: linux (Ubuntu 24.04 LTS) to 6.8.0-50.51 or later, linux-aws (Ubuntu 24.04 LTS) to 6.8.0-1020.22 or later, and linux-azure (Ubuntu 24.04 LTS) to 6.8.0-1020.23 or later. Apply updates via standard package management and restart affected services.

How to confirm the fix worked

Verify installed package versions match or exceed the listed fixed releases, then test with known-good and crafted multipart requests to confirm the application no longer crashes on malformed input.

Typical attack path

  1. Identify a target application or server using the vulnerable libsoup library
  2. Craft a specially malformed multipart message that triggers the integer underflow
  3. Transmit the message over HTTP to the target
  4. Observe the resulting crash and service interruption

How to detect it

Review application and system logs for unexpected crashes or segmentation faults occurring shortly after receipt of HTTP requests containing multipart content; correlate with web server access logs showing unusual multipart payloads.

What your security team should do

  • Apply the listed kernel package updates immediately across all affected Ubuntu 24.04 LTS systems
  • Prioritize internet-facing services that handle HTTP multipart content
  • Monitor for application crashes correlated with incoming HTTP traffic until patches are deployed

The record

A flaw was found in the soup_multipart_new_from_message() function of the libsoup HTTP library, which is commonly used by GNOME and other applications to handle web communications. The issue occurs when the library processes specially crafted multipart messages. Due to improper validation, an internal calculation can go wrong, leading to an integer underflow. This can cause the program to access invalid memory and crash. As a result, any application or server using libsoup could be forced to exit unexpectedly, creating a denial-of-service (DoS) risk.

Affected packages

Ecosystem Package Introduced Fixed
AlmaLinux:10 libsoup3 0 3.6.5-3.el10_0.6
AlmaLinux:10 libsoup3-devel 0 3.6.5-3.el10_0.6
AlmaLinux:10 libsoup3-doc 0 3.6.5-3.el10_0.6
AlmaLinux:8 libsoup 0 2.62.3-9.el8_10
AlmaLinux:8 libsoup-devel 0 2.62.3-9.el8_10
AlmaLinux:9 libsoup 0 2.72.0-10.el9_6.2
AlmaLinux:9 libsoup-devel 0 2.72.0-10.el9_6.2
Debian:11 libsoup2.4 0 No fix
Debian:12 libsoup2.4 0 No fix
Debian:12 libsoup3 0 No fix
Debian:13 libsoup2.4 0 No fix
Debian:13 libsoup3 0 No fix
Debian:14 libsoup2.4 0 No fix
Debian:14 libsoup3 0 3.6.5-2
SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS libsoup 0 3.0.4-150400.3.10.1
SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS libsoup2 0 2.74.2-150400.3.9.1
SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS libsoup 0 3.0.4-150400.3.10.1
SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS libsoup2 0 2.74.2-150400.3.9.1
SUSE:Linux Enterprise High Performance Computing 15 SP5-ESPOS libsoup 0 3.0.4-150400.3.10.1
SUSE:Linux Enterprise High Performance Computing 15 SP5-ESPOS libsoup2 0 2.74.2-150400.3.9.1
SUSE:Linux Enterprise High Performance Computing 15 SP5-LTSS libsoup 0 3.0.4-150400.3.10.1
SUSE:Linux Enterprise High Performance Computing 15 SP5-LTSS libsoup2 0 2.74.2-150400.3.9.1
SUSE:Linux Enterprise Micro 5.3 libsoup2 0 2.74.2-150400.3.9.1
SUSE:Linux Enterprise Micro 5.4 libsoup2 0 2.74.2-150400.3.9.1
SUSE:Linux Enterprise Micro 5.5 libsoup2 0 2.74.2-150400.3.9.1
SUSE:Linux Enterprise Module for Basesystem 15 SP6 libsoup 0 3.4.4-150600.3.10.1
SUSE:Linux Enterprise Module for Basesystem 15 SP6 libsoup2 0 2.74.3-150600.4.9.1
SUSE:Linux Enterprise Module for Basesystem 15 SP7 libsoup 0 3.4.4-150600.3.10.1
SUSE:Linux Enterprise Module for Basesystem 15 SP7 libsoup2 0 2.74.3-150600.4.9.1
SUSE:Linux Enterprise Server 15 SP4-LTSS libsoup 0 3.0.4-150400.3.10.1
SUSE:Linux Enterprise Server 15 SP4-LTSS libsoup2 0 2.74.2-150400.3.9.1
SUSE:Linux Enterprise Server 15 SP5-LTSS libsoup 0 3.0.4-150400.3.10.1
SUSE:Linux Enterprise Server 15 SP5-LTSS libsoup2 0 2.74.2-150400.3.9.1
SUSE:Linux Enterprise Server for SAP Applications 15 SP4 libsoup 0 3.0.4-150400.3.10.1
SUSE:Linux Enterprise Server for SAP Applications 15 SP4 libsoup2 0 2.74.2-150400.3.9.1
SUSE:Linux Enterprise Server for SAP Applications 15 SP5 libsoup 0 3.0.4-150400.3.10.1
SUSE:Linux Enterprise Server for SAP Applications 15 SP5 libsoup2 0 2.74.2-150400.3.9.1
SUSE:Manager Proxy 4.3 libsoup 0 3.0.4-150400.3.10.1
SUSE:Manager Proxy 4.3 libsoup2 0 2.74.2-150400.3.9.1
SUSE:Manager Server 4.3 libsoup 0 3.0.4-150400.3.10.1
SUSE:Manager Server 4.3 libsoup2 0 2.74.2-150400.3.9.1
openSUSE:Leap 15.6 libsoup 0 3.4.4-150600.3.10.1
openSUSE:Leap 15.6 libsoup2 0 2.74.3-150600.4.9.1
openSUSE:Tumbleweed libsoup 0 3.6.5-5.1
openSUSE:Tumbleweed libsoup2 0 2.74.3-11.1

Related vulnerabilities