CVE-2025-4878
Low · 3.6CVSS
3.6
EPSS
0.2%
Published
Jul 22, 2025
CISA due date
—
Cloudanix analysis
A missing-file bug in a secure-connection library used by some database packages can make programs crash or act incorrectly until the software is updated.
- Exploitation
- Local Privilege
- Attacker needs
- Low Privilege
- Complexity
- High
- Impact
- Data Tampering
- Component
- Library
- Class
- Memory Corruption
- Remediation
- Upgrade
- Effort
- Medium
- Patch risk
- Low
What it actually does
Uninitialized variable in libssh privatekey_from_file() when the specified filename does not exist, resulting in possible signing failures or heap corruption under MemoryCorruption conditions.
Why it matters to the business
May cause SSH-related operations in affected software such as PostgreSQL deployments to fail or crash, leading to disrupted secure connections and requiring urgent patching in environments using the vulnerable library.
How an attack unfolds
An attacker with local access supplies a non-existent filename to trigger privatekey_from_file(), exploiting the uninitialized variable to induce heap corruption or signing errors; low EPSS and no KEV or ransomware association indicate limited real-world exploitation despite a modest 23% EPSS rise over 30 days.
How to fix it
Upgrade postgresql (Bitnami) to version 13.22.0 or later; rebuild or update any downstream packages that embed the vulnerable libssh version.
How to confirm the fix worked
Verify the installed postgresql (Bitnami) version is at least 13.22.0; test privatekey_from_file() behavior with deliberately missing files to confirm absence of corruption or signing anomalies.
Typical attack path
- Obtain local access to the target system
- Identify or induce a call to privatekey_from_file() with a non-existent key file path
- Trigger the uninitialized variable condition to cause heap corruption or signing failure
How to detect it
Review application logs for unexpected SSH signing failures or heap-related crashes when key files are referenced; correlate with local process execution attempting to load non-existent private keys.
What your security team should do
- Immediately upgrade postgresql (Bitnami) to 13.22.0 across all instances
- Scan for other applications using vulnerable libssh versions and prioritize updates
- Monitor EPSS trend and reassess exploit maturity as new data emerges
The record
A vulnerability was found in libssh, where an uninitialized variable exists under certain conditions in the privatekey_from_file() function. This flaw can be triggered if the file specified by the filename doesn't exist and may lead to possible signing failures or heap corruption.
Affected packages
| Ecosystem | Package | Introduced | Fixed |
|---|---|---|---|
| Debian:11 | libssh | 0 | No fix |
| Debian:12 | libssh | 0 | No fix |
| Debian:13 | libssh | 0 | 0.11.2-1 |
| SUSE:Linux Enterprise Module for Basesystem 15 SP6 | libssh | 0 | 0.9.8-150600.11.3.1 |
| SUSE:Linux Enterprise Module for Basesystem 15 SP7 | libssh | 0 | 0.9.8-150600.11.3.1 |
| SUSE:Linux Enterprise Server 12 SP5-LTSS | libssh | 0 | 0.6.3-12.15.1 |
| SUSE:Linux Enterprise Server LTSS Extended Security 12 SP5 | libssh | 0 | 0.6.3-12.15.1 |
| openSUSE:Leap 15.6 | libssh | 0 | 0.9.8-150600.11.3.1 |
| openSUSE:Tumbleweed | libssh | 0 | 0.11.2-1.1 |
Related vulnerabilities
- CVE-2025-8277 A flaw was found in libssh's handling of key exchange (KEX) processes when a client… Also affects libssh
- CVE-2025-4877 There's a vulnerability in the libssh package where when a libssh consumer passes in an… Also affects libssh
- CVE-2025-8114 A flaw was found in libssh, a library that implements the SSH protocol. Also affects libssh
- CVE-2025-5987 A flaw was found in libssh when using the ChaCha20 cipher with the OpenSSL library. Also affects libssh
- CVE-2025-5351 A flaw was found in the key export functionality of libssh. Also affects libssh
- CVE-2025-5372 A flaw was found in libssh versions built with OpenSSL versions older than 3.0… Also affects libssh
- CVE-2025-5318 A flaw was found in the libssh library in versions less than 0.11.2. Also affects libssh
- CVE-2015-3146 The (1) SSH_MSG_NEWKEYS and (2) SSH_MSG_KEXDH_REPLY packet handlers in package_cb.c in… Also affects libssh