CVE-2025-32989
Medium · 5.3CVSS
5.3
EPSS
1.5%
Published
Jul 10, 2025
CISA due date
—
Cloudanix analysis
A flaw in how some software reads website security certificates could let attackers see pieces of private information stored in memory.
- Exploitation
- Remote Unauthenticated
- Attacker needs
- None
- Complexity
- Low
- Impact
- Data Exposure
- Component
- Library
- Class
- Memory Corruption
- Remediation
- Upgrade
- Effort
- Medium
- Patch risk
- Low
What it actually does
Heap-buffer-overread in GnuTLS during X.509 certificate parsing of the SCT extension (OID 1.3.6.1.4.1.11129.2.4.2) that exposes adjacent memory contents when the extension is malformed.
Why it matters to the business
Systems using the affected package may leak confidential memory data during routine certificate verification from remote sites, increasing risk of information disclosure in high-volume TLS environments.
How an attack unfolds
An attacker creates a certificate containing a deliberately malformed SCT extension and presents it during a TLS handshake; vulnerable GnuTLS parsing code performs an out-of-bounds read that returns sensitive process memory to the attacker.
How to fix it
Upgrade @account-kit/smart-contracts to version 4.52.0 or later; rebuild and redeploy all dependent services; verify the new package resolves the GnuTLS parsing path.
How to confirm the fix worked
Confirm installed package version is at least 4.52.0; run regression tests that submit both valid and malformed SCT certificates to exercise the fixed parsing code.
Typical attack path
- Generate X.509 certificate embedding a crafted SCT extension
- Host the certificate on a controlled server or MITM position
- Force the target application to perform certificate verification
- Trigger the overread path in GnuTLS SCT handling
- Capture leaked memory contents containing sensitive data
How to detect it
Review TLS handshake and certificate parsing logs for entries involving SCT extension processing; correlate with memory access anomalies or unexpected data in application error streams; no specific actor-linked patterns are known.
What your security team should do
- Immediately upgrade @account-kit/smart-contracts to 4.52.0 across all environments
- Prioritize scanning and updating any services that perform outbound TLS certificate validation
- Add package version checks to CI/CD pipelines to prevent regression
- Monitor upstream GnuTLS advisories for related fixes
The record
A heap-buffer-overread vulnerability was found in GnuTLS in how it handles the Certificate Transparency (CT) Signed Certificate Timestamp (SCT) extension during X.509 certificate parsing. This flaw allows a malicious user to create a certificate containing a malformed SCT extension (OID 1.3.6.1.4.1.11129.2.4.2) that contains sensitive data. This issue leads to the exposure of confidential information when GnuTLS verifies certificates from certain websites when the certificate (SCT) is not checked correctly.
Affected packages
| Ecosystem | Package | Introduced | Fixed |
|---|---|---|---|
| AlmaLinux:10 | gnutls | 0 | 3.8.9-9.el10_0.14 |
| AlmaLinux:10 | gnutls-c++ | 0 | 3.8.9-9.el10_0.14 |
| AlmaLinux:10 | gnutls-dane | 0 | 3.8.9-9.el10_0.14 |
| AlmaLinux:10 | gnutls-devel | 0 | 3.8.9-9.el10_0.14 |
| AlmaLinux:10 | gnutls-fips | 0 | 3.8.9-9.el10_0.14 |
| AlmaLinux:10 | gnutls-utils | 0 | 3.8.9-9.el10_0.14 |
| AlmaLinux:9 | gnutls | 0 | 3.8.3-6.el9_6.2 |
| AlmaLinux:9 | gnutls-c++ | 0 | 3.8.3-6.el9_6.2 |
| AlmaLinux:9 | gnutls-dane | 0 | 3.8.3-6.el9_6.2 |
| AlmaLinux:9 | gnutls-devel | 0 | 3.8.3-6.el9_6.2 |
| AlmaLinux:9 | gnutls-utils | 0 | 3.8.3-6.el9_6.2 |
| Debian:11 | gnutls28 | 0 | No fix |
| Debian:12 | gnutls28 | 0 | No fix |
| Debian:13 | gnutls28 | 0 | No fix |
| Debian:14 | gnutls28 | 0 | 3.8.9-3 |
| Mageia:9 | gnutls | 0 | 3.8.4-1.2.mga9 |
| SUSE:Linux Enterprise Module for Basesystem 15 SP6 | gnutls | 0 | 3.8.3-150600.4.9.1 |
| SUSE:Linux Enterprise Module for Basesystem 15 SP7 | gnutls | 0 | 3.8.3-150600.4.9.1 |
| openSUSE:Leap 15.6 | gnutls | 0 | 3.8.3-150600.4.9.1 |
| openSUSE:Tumbleweed | gnutls | 0 | 3.8.10-1.1 |
Related vulnerabilities
- CVE-2025-6395 A NULL pointer dereference flaw was found in the GnuTLS software in… Also affects gnutls
- CVE-2025-32990 A heap-buffer-overflow (off-by-one) flaw was found in the GnuTLS software in the template… Also affects gnutls
- CVE-2025-32988 A flaw was found in GnuTLS. Also affects gnutls
- CVE-2024-12243 A flaw was found in GnuTLS, which relies on libtasn1 for ASN.1 data processing. Also affects gnutls
- CVE-2024-28834 A flaw was found in GnuTLS. Also affects gnutls
- CVE-2024-28835 A flaw has been discovered in GnuTLS where an application crash can be induced when… Also affects gnutls
- CVE-2024-0553 A vulnerability was found in GnuTLS. Also affects gnutls
- CVE-2023-5981 A vulnerability was found that the response times to malformed ciphertexts in RSA-PSK… Also affects gnutls