Cloudanix VulnDB

CVE-2025-15444

Critical · 9.8

CVSS

9.8

EPSS

0.3%

Published

Jan 6, 2026

CISA due date

—

The record

Crypt::Sodium::XS module versions prior to 0.000042, for Perl, include a vulnerable version of libsodium libsodium <= 1.0.20 or a version of libsodium released before December 30, 2025 contains a vulnerability documented as CVE-2025-69277  https://www.cve.org/CVERecord?id=CVE-2025-69277 . The libsodium vulnerability states: In atypical use cases involving certain custom cryptography or untrusted data to crypto_core_ed25519_is_valid_point, mishandles checks for whether an elliptic curve point is valid because it sometimes allows points that aren't in the main cryptographic group. 0.000042 includes a version of libsodium updated to 1.0.20-stable, released January 3, 2026, which includes a fix for the vulnerability.

Affected packages

Ecosystem Package Introduced Fixed
SUSE:Linux Enterprise Micro 5.2 libsodium 0 1.0.18-150000.4.11.1
SUSE:Linux Enterprise Micro 5.2 libsodium 0 1.0.18-150000.4.14.1
SUSE:Linux Enterprise Micro 5.3 libsodium 0 1.0.18-150000.4.11.1
SUSE:Linux Enterprise Micro 5.3 libsodium 0 1.0.18-150000.4.14.1
SUSE:Linux Enterprise Micro 5.4 libsodium 0 1.0.18-150000.4.11.1
SUSE:Linux Enterprise Micro 5.4 libsodium 0 1.0.18-150000.4.14.1
SUSE:Linux Enterprise Micro 5.5 libsodium 0 1.0.18-150000.4.11.1
SUSE:Linux Enterprise Micro 5.5 libsodium 0 1.0.18-150000.4.14.1
SUSE:Linux Enterprise Module for Basesystem 15 SP7 libsodium 0 1.0.18-150000.4.11.1
SUSE:Linux Enterprise Module for Basesystem 15 SP7 libsodium 0 1.0.18-150000.4.14.1
SUSE:Linux Enterprise Module for Public Cloud 12 libsodium 0 1.0.16-1.15.1
openSUSE:Leap 15.6 libsodium 0 1.0.18-150000.4.11.1
openSUSE:Leap 15.6 libsodium 0 1.0.18-150000.4.14.1
openSUSE:Leap 16.0 libsodium 0 1.0.20-160000.3.1
openSUSE:Tumbleweed libsodium 0 1.0.21-1.1

Related vulnerabilities