CVE-2024-6484
Medium · 6.4CVSS
6.4
EPSS
—
Published
Jul 11, 2024
CISA due date
—
Cloudanix analysis
A flaw in a widely used web design library lets attackers run harmful code inside users' browsers when they view certain image sliders on a website.
- Exploitation
- Requires User Interaction
- Attacker needs
- User Interaction
- Complexity
- Moderate
- Impact
- Remote Code Execution
- Component
- Library
- Class
- XSS
- Remediation
- Upgrade
- Effort
- Medium
- Patch risk
- Low
What it actually does
Unsanitized data-slide and data-slide-to attributes on anchor tags within the carousel component allow injection and execution of arbitrary JavaScript in the victim's browser context.
Why it matters to the business
Websites using the affected Bootstrap version can be abused to run malicious code in visitors' browsers, risking stolen credentials, session hijacking, or site defacement that erodes user trust and may trigger regulatory scrutiny.
How an attack unfolds
An attacker crafts a malicious anchor element containing executable JavaScript inside the data-slide or data-slide-to attribute, places it inside a Bootstrap carousel on a page the victim visits, and triggers execution when the carousel processes the attribute without sanitization.
How to fix it
Upgrade twitter-bootstrap3 to the fixed package versions: 3.4.1+dfsg-4 on Debian 13, 3.4.1+dfsg-2+deb11u1 on Debian 11, or 3.4.1+dfsg-3+deb12u1 on Debian 12. Replace all instances of the carousel markup and bootstrap.js files with the patched release.
How to confirm the fix worked
Verify the installed package version matches one of the fixed releases, inspect rendered carousel HTML to confirm data attributes are properly escaped, and run automated markup scanners against sample pages containing carousels.
Typical attack path
- Locate a web page using the vulnerable Bootstrap carousel component
- Inject an anchor tag with a crafted href or data attribute containing a JavaScript payload
- Lure a victim to interact with the carousel (click or slide)
- Execute arbitrary JavaScript in the victim's browser session
How to detect it
Review web server access logs and application logs for requests containing suspicious data-slide or data-slide-to values; inspect rendered page source for unexpected script execution in carousel markup; monitor browser console or security event logs for unauthorized JavaScript activity on pages using carousels.
What your security team should do
- Immediately update all instances of twitter-bootstrap3 to the listed fixed Debian package versions
- Audit all web applications for remaining copies of the vulnerable carousel component
- Implement content-security-policy headers to restrict inline script execution as a defense-in-depth measure
- Add Bootstrap version checks to continuous integration pipelines to prevent regression
The record
A vulnerability has been identified in Bootstrap that exposes users to Cross-Site Scripting (XSS) attacks. The issue is present in the carousel component, where the data-slide and data-slide-to attributes can be exploited through the href attribute of an <a> tag due to inadequate sanitization. This vulnerability could potentially enable attackers to execute arbitrary JavaScript within the victim's browser.
Affected packages
| Ecosystem | Package | Introduced | Fixed |
|---|---|---|---|
| Maven | org.webjars.npm:bootstrap | 2.0.0 | No fix |
| Maven | org.webjars:bootstrap | 2.0.0 | No fix |
| NuGet | bootstrap | 2.0.0 | No fix |
| NuGet | bootstrap.sass | 2.0.0 | No fix |
| Packagist | twbs/bootstrap | 2.0.0 | No fix |
| RubyGems | bootstrap | 2.0.0 | No fix |
| RubyGems | bootstrap-sass | 2.0.0 | No fix |
| npm | bootstrap | 2.0.0 | No fix |
| npm | bootstrap-sass | 2.0.0 | No fix |
| Chainguard | jupyter-base-notebook | 0 | 7.4.7-r0 |
| Chainguard | rancher-api-ui | 0 | 1.2.3-r3 |
| Debian:11 | twitter-bootstrap3 | 0 | No fix |
| Debian:11 | twitter-bootstrap3 | 0 | 3.4.1+dfsg-2+deb11u1 |
| Debian:12 | twitter-bootstrap3 | 0 | No fix |
| Debian:12 | twitter-bootstrap3 | 0 | 3.4.1+dfsg-3+deb12u1 |
| Debian:13 | twitter-bootstrap3 | 0 | No fix |
| Debian:13 | twitter-bootstrap3 | 0 | 3.4.1+dfsg-4 |
| Ubuntu:20.04:LTS | twitter-bootstrap3 | 0 | No fix |
| Ubuntu:20.04:LTS | twitter-bootstrap4 | 0 | No fix |
| Ubuntu:22.04:LTS | twitter-bootstrap3 | 0 | No fix |
| Ubuntu:22.04:LTS | twitter-bootstrap3 | 0 | 3.4.1+dfsg-2+deb11u2build0.22.04.1 |
| Ubuntu:22.04:LTS | twitter-bootstrap4 | 0 | No fix |
| Ubuntu:24.04:LTS | twitter-bootstrap3 | 0 | No fix |
| Ubuntu:24.04:LTS | twitter-bootstrap3 | 0 | 3.4.1+dfsg-3+deb12u1build0.24.04.1 |
| Ubuntu:24.04:LTS | twitter-bootstrap4 | 0 | No fix |
| Ubuntu:24.10 | twitter-bootstrap3 | 0 | No fix |
| Ubuntu:24.10 | twitter-bootstrap4 | 0 | No fix |
| Ubuntu:25.04 | twitter-bootstrap3 | 0 | 3.4.1+dfsg-3+deb12u1build0.25.04.1 |
| Ubuntu:Pro:16.04:LTS | twitter-bootstrap3 | 0 | No fix |
| Ubuntu:Pro:16.04:LTS | twitter-bootstrap3 | 0 | 3.3.6+dfsg-1ubuntu0.1~esm1 |
| Ubuntu:Pro:18.04:LTS | twitter-bootstrap3 | 0 | No fix |
| Ubuntu:Pro:18.04:LTS | twitter-bootstrap3 | 0 | 3.3.7+dfsg-2ubuntu0.1~esm1 |
| Wolfi | jupyter-base-notebook | 0 | 7.4.7-r0 |
| Wolfi | rancher-api-ui | 0 | 1.2.3-r3 |
| gem | bootstrap | 2.0.0 | No fix |
| gem | bootstrap-sass | 2.0.0 | No fix |
| maven | org.webjars.npm/bootstrap | 2.0.0 | No fix |
| maven | org.webjars/bootstrap | 2.0.0 | No fix |
| nuget | bootstrap | 2.0.0 | No fix |
| nuget | bootstrap.sass | 2.0.0 | No fix |
| packagist | twbs/bootstrap | 2.0.0 | No fix |
Related vulnerabilities
- CVE-2024-6531 A vulnerability has been identified in Bootstrap that exposes users to Cross-Site… Also affects org.webjars.npm:bootstrap
- CVE-2025-1647 Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site… Also affects bootstrap
- CVE-2024-6485 A security vulnerability has been discovered in bootstrap that could enable Cross-Site… Also affects bootstrap
- CVE-2026-34073 cryptography is a package designed to expose cryptographic primitives and recipes to… Also affects jupyter-base-notebook
- CVE-2026-25645 Requests is a HTTP library. Also affects jupyter-base-notebook
- CVE-2026-4539 A security flaw has been discovered in pygments up to 2.19.2. Also affects jupyter-base-notebook
- CVE-2026-26007 cryptography is a package designed to expose cryptographic primitives and recipes to… Also affects jupyter-base-notebook
- CVE-2026-21441 Decompression-bomb safeguards bypassed when following HTTP redirects (streaming API) Also affects jupyter-base-notebook