Cloudanix VulnDB

CVE-2024-52012

None

Apache Solr Relative Path Traversal vulnerability

CVSS

—

EPSS

45.0%

Published

Jan 27, 2025

CISA due date

—

The record

Relative Path Traversal vulnerability in Apache Solr. Solr instances running on Windows are vulnerable to arbitrary filepath write-access, due to a lack of input-sanitation in the "configset upload" API.  Commonly known as a "zipslip", maliciously constructed ZIP files can use relative filepaths to write data to unanticipated parts of the filesystem. This issue affects Apache Solr: from 6.6 through 9.7.0. Users are recommended to upgrade to version 9.8.0, which fixes the issue.  Users unable to upgrade may also safely prevent the issue by using Solr's "Rule-Based Authentication Plugin" to restrict access to the configset upload API, so that it can only be accessed by a trusted set of administrators/users.

Affected packages

Ecosystem Package Introduced Fixed
Maven org.apache.solr:solr-core 6.6 9.8.0
Bitnami solr 6.6.0 9.8.0
Chainguard solr 0 0
Chainguard solr-oci-compat 0 0
Wolfi solr 0 0
Wolfi solr-oci-compat 0 0
maven org.apache.solr/solr-core 6.6 9.8.0

Related vulnerabilities