CVE-2024-39894
High · 7.5CVSS
7.5
EPSS
1.6%
Published
Jul 2, 2024
CISA due date
—
Cloudanix analysis
A flaw in certain versions of the secure remote login software can let attackers guess passwords by watching tiny timing differences when users type them without the characters appearing on screen.
- Exploitation
- Requires User Interaction
- Attacker needs
- User Interaction
- Complexity
- High
- Impact
- Full Compromise
- Component
- Network Service
- Class
- Information Disclosure
- Remediation
- Upgrade
- Effort
- Medium
- Patch risk
- Low
What it actually does
A logic error in ObscureKeystrokeTiming permits timing side-channel attacks that can leak information about keystrokes entered without echo during password prompts for utilities such as su and sudo.
Why it matters to the business
Successful exploitation can allow credential disclosure, enabling attackers to obtain elevated access and potentially compromise systems that rely on interactive authentication.
How an attack unfolds
An attacker observes measurable differences in processing time for password entry in affected OpenSSH versions to infer character content or length, then uses the recovered information to authenticate as the target user.
How to fix it
Upgrade OpenSSH to version 9.8 or later. On Debian 12 apply package version 6.1.85-1; on Debian 13 apply package version 6.7.12-1.
How to confirm the fix worked
Confirm the installed OpenSSH version is 9.8 or newer, or verify that the operating-system package versions match the listed fixed releases for the respective distribution.
Typical attack path
- Locate systems running vulnerable OpenSSH versions between 9.5 and 9.7
- Gain a vantage point allowing observation of network or local timing for authentication prompts
- Trigger password entry for su, sudo, or similar commands
- Measure and analyze timing variations to reconstruct password data
- Authenticate using recovered credentials to escalate privileges
How to detect it
Examine system and authentication logs for repeated or unusual interactive login attempts around su or sudo usage; timing-based attacks themselves leave no distinctive artifacts in standard logs.
What your security team should do
- Apply the available package updates for OpenSSH on all affected Debian systems
- Review authentication configurations to reduce reliance on echo-off password entry where feasible
- Monitor authentication logs for anomalous patterns after patching
The record
OpenSSH 9.5 through 9.7 before 9.8 sometimes allows timing attacks against echo-off password entry (e.g., for su and Sudo) because of an ObscureKeystrokeTiming logic error. Similarly, other timing attacks against keystroke entry could occur.
Affected packages
| Ecosystem | Package | Introduced | Fixed |
|---|---|---|---|
| Debian:13 | openssh | 0 | 1:9.8p1-1 |
| SUSE:Linux Enterprise Module for Basesystem 15 SP6 | openssh | 0 | 9.6p1-150600.6.6.1 |
| SUSE:Linux Enterprise Module for Desktop Applications 15 SP6 | openssh-askpass-gnome | 0 | 9.6p1-150600.6.6.1 |
| Ubuntu:24.04:LTS | openssh | 0 | 1:9.6p1-3ubuntu13.4 |
| openSUSE:Leap 15.6 | openssh | 0 | 9.6p1-150600.6.6.1 |
| openSUSE:Leap 15.6 | openssh-askpass-gnome | 0 | 9.6p1-150600.6.6.1 |
| openSUSE:Tumbleweed | openssh | 0 | 9.6p1-11.1 |
Related vulnerabilities
- CVE-2025-26466 A flaw was found in the OpenSSH package. Also affects openssh
- CVE-2024-6387 A security regression (CVE-2006-5051) was discovered in OpenSSH's server (sshd). Also affects openssh
- CVE-2023-51385 In ssh in OpenSSH before 9.6, OS command injection might occur if a user name or host… Also affects openssh
- CVE-2023-51384 In ssh-agent in OpenSSH before 9.6, certain destination constraints can be incompletely… Also affects openssh
- CVE-2023-28531 ssh-add in OpenSSH before 9.3 adds smartcard keys to ssh-agent without the intended… Also affects openssh
- CVE-2023-25136 OpenSSH server (sshd) 9.1 introduced a double-free vulnerability during… Also affects openssh
- CVE-2021-41617 sshd in OpenSSH 6.2 through 8.x before 8.8, when certain non-default configurations are… Also affects openssh
- CVE-2016-10708 sshd in OpenSSH before 7.4 allows remote attackers to cause a denial of service (NULL… Also affects openssh