CVE-2024-3325
NoneCVSS
—
EPSS
0.6%
Published
Jul 10, 2024
CISA due date
—
Cloudanix analysis
A flaw in certain versions of the reporting server could let someone with admin rights cause serious problems with data and operations if left unaddressed.
- Exploitation
- Remote Authenticated
- Attacker needs
- High Privilege
- Complexity
- Low
- Impact
- Full Compromise
- Component
- Application
- Class
- Other
- Remediation
- Upgrade
- Effort
- Medium
- Patch risk
- Medium
What it actually does
The vulnerability permits a high-privileged network attacker to fully compromise confidentiality, integrity, and availability of the JasperReport Server instance.
Why it matters to the business
Successful exploitation can result in unauthorized access to sensitive reports and data, potential service disruption, and loss of trust in business intelligence systems; low EPSS and no known exploitation reduce immediate risk but high CVSS warrants prompt attention given the age of the disclosure.
How an attack unfolds
An attacker authenticates using an existing high-privilege account, crafts and sends specially formed requests to the affected server versions, and leverages the flaw to execute actions that breach the server’s data and functionality.
How to fix it
Upgrade JasperReport Server to the latest fixed version beyond 9.0.0 as soon as it becomes available from the vendor; restrict administrative access in the interim and monitor for abnormal privileged activity.
How to confirm the fix worked
Inventory all JasperReport Server deployments and confirm none are running versions 8.0.4 through 9.0.0; re-test after applying vendor updates to ensure the vulnerable range is no longer present.
Typical attack path
- Obtain or compromise a high-privileged account on the JasperReport Server
- Send malicious network requests targeting the vulnerable endpoints in versions 8.0.4 through 9.0.0
- Achieve full control over server data and operations
How to detect it
Examine JasperReport Server access and application logs for anomalous requests originating from high-privilege accounts; correlate with network traffic to the server over the publication period.
What your security team should do
- Immediately identify and isolate any JasperReport Server instances in the affected version range
- Apply vendor patches or upgrades as soon as released
- Enforce least-privilege access for all administrative accounts
- Increase logging and alerting on privileged operations until remediation is complete
The record
Vulnerability in Jaspersoft JasperReport Servers.This issue affects JasperReport Servers: from 8.0.4 through 9.0.0.
Affected packages
| Ecosystem | Package | Introduced | Fixed |
|---|---|---|---|
| Ubuntu:16.04:LTS | jasperreports | 0 | No fix |
| Ubuntu:18.04:LTS | jasperreports | 0 | No fix |
| Ubuntu:Pro:16.04:LTS | jasperreports | 0 | No fix |
| Ubuntu:Pro:18.04:LTS | jasperreports | 0 | No fix |
Related vulnerabilities
- CVE-2022-41563 The Dashboard component of TIBCO Software Inc.'s TIBCO JasperReports Server, TIBCO… Also affects jasperreports
- CVE-2022-41561 The JNDI Data Sources component of TIBCO Software Inc.'s TIBCO JasperReports Server… Also affects jasperreports
- CVE-2022-41562 The HTML escaping component of TIBCO Software Inc.'s TIBCO JasperReports Server, TIBCO… Also affects jasperreports
- CVE-2022-22771 The Server component of TIBCO Software Inc.'s TIBCO JasperReports Library, TIBCO… Also affects jasperreports
- CVE-2018-5430 The Spring web flows of TIBCO Software Inc.'s TIBCO JasperReports Server, TIBCO… Also affects jasperreports
- CVE-2026-114658 Grav Login plugin from 3.6.0 before 3.9.13 contains a missing authorization vulnerability… CWE-269
- CVE-2026-53614 util-linux is a random collection of Linux utilities. CWE-269
- CVE-2026-95837 containerd is an open-source container runtime. CWE-269