CVE-2023-46316
Medium · 5.5CVSS
5.5
EPSS
0.4%
Published
Oct 25, 2023
CISA due date
—
Cloudanix analysis
A local user can feed bad input to an old network tool and make it stop working or run unwanted commands.
- Exploitation
- Local Privilege
- Attacker needs
- Low Privilege
- Complexity
- Low
- Impact
- Denial Of Service
- Component
- Application
- Class
- Command Injection
- Remediation
- Upgrade
- Effort
- Low
- Patch risk
- Low
What it actually does
The flaw permits local command injection because wrapper scripts fail to properly parse command lines, allowing crafted arguments to execute unintended commands and trigger denial of service.
Why it matters to the business
Attackers with local access can disrupt network diagnostic operations, causing service outages or degraded availability on systems relying on the affected traceroute tool.
How an attack unfolds
An attacker with local user privileges supplies specially formatted command-line arguments to the vulnerable wrapper scripts; improper parsing results in execution of attacker-controlled commands that lead to denial of service.
How to fix it
Upgrade buc Traceroute to version 2.1.3 or later. For gnutls/gnutls (GIT) deployments apply the fix in commit 009b21c13bc62ff84d5175ca1626fbf08adf5a09.
How to confirm the fix worked
Confirm the installed buc Traceroute version is 2.1.3 or newer; verify gnutls/gnutls (GIT) is at commit 009b21c13bc62ff84d5175ca1626fbf08adf5a09 or later and test wrapper script parsing with known-safe inputs.
Typical attack path
- Locate an installation of buc Traceroute between versions 2.0.12 and 2.1.2
- Craft malicious command-line input targeting the wrapper scripts
- Invoke the affected script with the crafted arguments
- Trigger arbitrary command execution resulting in denial of service
How to detect it
Examine system and process logs for unexpected command executions or crashes originating from buc Traceroute wrapper scripts; look for anomalous argument patterns in shell history or audit logs around the time of service disruption.
What your security team should do
- Immediately upgrade all affected buc Traceroute installations to 2.1.3 or newer
- Apply the referenced gnutls/gnutls commit if the library is present in the environment
- Review local processes and scripts that invoke traceroute for unsanitized argument handling
- Monitor for any post-upgrade behavioral changes in network diagnostics
The record
In buc Traceroute 2.0.12 through 2.1.2 before 2.1.3, the wrapper scripts do not properly parse command lines.
Affected packages
| Ecosystem | Package | Introduced | Fixed |
|---|---|---|---|
| AlmaLinux:8 | traceroute | 0 | 3:2.1.0-8.el8 |
| AlmaLinux:9 | traceroute | 0 | 3:2.1.0-18.el9 |
| Debian:11 | traceroute | 0 | No fix |
| Debian:12 | traceroute | 0 | No fix |
| Debian:13 | traceroute | 0 | 1:2.1.3-1 |
| Debian:14 | traceroute | 0 | 1:2.1.3-1 |
| Mageia:9 | traceroute | 0 | 2.1.3-1.mga9 |
| Red Hat:enterprise_linux:8::baseos | traceroute | 0 | 3:2.1.0-8.el8 |
| Red Hat:enterprise_linux:8::baseos | traceroute-debuginfo | 0 | 3:2.1.0-8.el8 |
| Red Hat:enterprise_linux:8::baseos | traceroute-debugsource | 0 | 3:2.1.0-8.el8 |
| Red Hat:enterprise_linux:9::baseos | traceroute | 0 | 3:2.1.0-18.el9 |
| Red Hat:enterprise_linux:9::baseos | traceroute-debuginfo | 0 | 3:2.1.0-18.el9 |
| Red Hat:enterprise_linux:9::baseos | traceroute-debugsource | 0 | 3:2.1.0-18.el9 |
| Rocky Linux:8 | traceroute | 0 | 3:2.1.0-8.el8 |
| SUSE:Linux Enterprise Micro 5.3 | traceroute | 0 | 2.0.21-150000.3.3.1 |
| SUSE:Linux Enterprise Micro 5.4 | traceroute | 0 | 2.0.21-150000.3.3.1 |
| SUSE:Linux Enterprise Micro 5.5 | traceroute | 0 | 2.0.21-150000.3.3.1 |
| SUSE:Linux Enterprise Module for Basesystem 15 SP4 | traceroute | 0 | 2.0.21-150000.3.3.1 |
| SUSE:Linux Enterprise Module for Basesystem 15 SP5 | traceroute | 0 | 2.0.21-150000.3.3.1 |
| SUSE:Linux Enterprise Server 12 SP5 | traceroute | 0 | 2.0.19-3.6.1 |
| SUSE:Linux Enterprise Server for SAP Applications 12 SP5 | traceroute | 0 | 2.0.19-3.6.1 |
| Ubuntu:20.04:LTS | traceroute | 0 | No fix |
| Ubuntu:22.04:LTS | traceroute | 0 | No fix |
| Ubuntu:24.04:LTS | traceroute | 0 | No fix |
| Ubuntu:24.10 | traceroute | 0 | No fix |
| Ubuntu:25.04 | traceroute | 0 | No fix |
| Ubuntu:25.10 | traceroute | 0 | No fix |
| Ubuntu:Pro:14.04:LTS | traceroute | 0 | 1:2.0.20-0ubuntu0.1+esm1 |
| Ubuntu:Pro:16.04:LTS | traceroute | 0 | 1:2.0.21-1ubuntu0.1~esm1 |
| Ubuntu:Pro:18.04:LTS | traceroute | 0 | 1:2.1.0-2ubuntu0.18.04.1~esm1 |
| Ubuntu:Pro:20.04:LTS | traceroute | 0 | 1:2.1.0-2ubuntu0.20.04.1~esm1 |
| Ubuntu:Pro:22.04:LTS | traceroute | 0 | 1:2.1.0-2ubuntu0.22.04.1~esm1 |
| openSUSE:Leap 15.4 | traceroute | 0 | 2.0.21-150000.3.3.1 |
| openSUSE:Leap 15.5 | traceroute | 0 | 2.0.21-150000.3.3.1 |
| openSUSE:Leap Micro 5.3 | traceroute | 0 | 2.0.21-150000.3.3.1 |
| openSUSE:Leap Micro 5.4 | traceroute | 0 | 2.0.21-150000.3.3.1 |
| openSUSE:Tumbleweed | traceroute | 0 | 2.1.3-1.1 |