CVE-2023-36915
High · 7.8CVSS
7.8
EPSS
0.4%
Published
Jan 8, 2024
CISA due date
—
Cloudanix analysis
Opening a specially made file in certain analysis software can let an attacker take control of the computer.
- Exploitation
- Requires User Interaction
- Attacker needs
- User Interaction
- Complexity
- Moderate
- Impact
- Full Compromise
- Component
- Application
- Class
- Memory Corruption
- Remediation
- Upgrade
- Effort
- Medium
- Patch risk
- Low
What it actually does
Integer overflow during chain_table array allocation in FST reader allows memory corruption that can result in arbitrary code execution when parsing a crafted file.
Why it matters to the business
Compromise of user workstations or build systems occurs when a malicious file is opened, with high urgency due to available exploits and over 1000 days of exposure; Debian freeipa packages require immediate updates across many environments.
How an attack unfolds
An attacker crafts an FST file that triggers an integer overflow in the chain_table allocation path; the victim opens the file in the vulnerable application, causing memory corruption that is turned into code execution. Public exploits exist and named threat actors have shown interest in similar memory corruption issues.
How to fix it
Upgrade freeipa on Debian 13 and 14 to version 4.12.2-1 or later; apply vendor patches for GTKWave 3.3.115 and later; verify all downstream dependents are updated given high ecosystem prevalence.
How to confirm the fix worked
Confirm application version is at or above the fixed release; test opening of known-good and crafted FST files in a sandbox to verify no crash or corruption occurs; review package manager output for successful upgrade to 4.12.2-1.
Typical attack path
- Craft malicious .fst file exploiting chain_table integer overflow
- Deliver file via email, download, or shared storage
- Victim opens file in vulnerable GTKWave instance
- Overflow leads to memory corruption and attacker-controlled code execution
How to detect it
Review file-open logs and process creation events for GTKWave or freeipa-related binaries handling .fst files; look for crashes or unusual memory allocations shortly after file access; check for any known threat actor tooling associated with similar FST parsing flaws.
- Process name: gtkwave
- File extension opened: .fst
- Crash signatures in application logs referencing chain_table allocation
What your security team should do
- Immediately update all affected freeipa installations to 4.12.2-1 on Debian 13 and 14
- Block opening of untrusted .fst files and enforce sandbox execution for file viewers
- Monitor EPSS trend and exploit availability; prioritize patching given ExploitAvailable status
- Scan for presence of older GTKWave or dependent packages across the environment
The record
Multiple integer overflow vulnerabilities exist in the FST fstReaderIterBlocks2 chain_table allocation functionality of GTKWave 3.3.115. A specially crafted .fst file can lead to arbitrary code execution. A victim would need to open a malicious file to trigger these vulnerabilities.This vulnerability concerns the allocation of the `chain_table` array.
Affected packages
| Ecosystem | Package | Introduced | Fixed |
|---|---|---|---|
| Debian:10 | gtkwave | 0 | 3.3.98+really3.3.118-0+deb10u1 |
| Debian:11 | gtkwave | 0 | 3.3.104+really3.3.118-0+deb11u1 |
| Debian:12 | gtkwave | 0 | 3.3.118-0.1~deb12u1 |
| Debian:13 | gtkwave | 0 | 3.3.118-0.1 |
| Ubuntu:16.04:LTS | gtkwave | 0 | No fix |
| Ubuntu:18.04:LTS | gtkwave | 0 | No fix |
| Ubuntu:20.04:LTS | gtkwave | 0 | No fix |
| Ubuntu:22.04:LTS | gtkwave | 0 | No fix |
| Ubuntu:24.04:LTS | gtkwave | 0 | No fix |
| Ubuntu:24.10 | gtkwave | 0 | No fix |
| Ubuntu:25.04 | gtkwave | 0 | No fix |
| Ubuntu:25.10 | gtkwave | 0 | No fix |
| Ubuntu:Pro:16.04:LTS | gtkwave | 0 | No fix |
| Ubuntu:Pro:18.04:LTS | gtkwave | 0 | No fix |
| Ubuntu:Pro:20.04:LTS | gtkwave | 0 | No fix |
Related vulnerabilities
- CVE-2023-39444 Multiple out-of-bounds write vulnerabilities exist in the LXT2 parsing functionality of… Also affects gtkwave
- CVE-2023-39317 Multiple integer overflow vulnerabilities exist in the LXT2 num_dict_entries… Also affects gtkwave
- CVE-2023-39414 Multiple integer underflow vulnerabilities exist in the LXT2 lxt2_rd_iter_radix shift… Also affects gtkwave
- CVE-2023-39413 Multiple integer underflow vulnerabilities exist in the LXT2 lxt2_rd_iter_radix shift… Also affects gtkwave
- CVE-2023-39443 Multiple out-of-bounds write vulnerabilities exist in the LXT2 parsing functionality of… Also affects gtkwave
- CVE-2023-39316 Multiple integer overflow vulnerabilities exist in the LXT2 num_dict_entries… Also affects gtkwave
- CVE-2023-39271 Multiple integer overflow vulnerabilities exist in the LXT2 facgeometry parsing… Also affects gtkwave
- CVE-2023-39273 Multiple integer overflow vulnerabilities exist in the LXT2 facgeometry parsing… Also affects gtkwave