CVE-2023-26364
Medium · 5.3CVSS
5.3
EPSS
1.2%
Published
Nov 17, 2023
CISA due date
—
Cloudanix analysis
A flaw in how certain media tools read CSS files could briefly slow down or interrupt processing when given unusual input, but the risk is low and updates are available.
- Exploitation
- Remote Unauthenticated
- Attacker needs
- None
- Complexity
- Low
- Impact
- Denial Of Service
- Component
- Library
- Class
- Improper Input Validation
- Remediation
- Upgrade
- Effort
- Medium
- Patch risk
- Low
What it actually does
Improper input validation during CSS parsing allows a crafted stylesheet to trigger a minor denial of service condition without authentication or user interaction.
Why it matters to the business
Low-likelihood service degradation for media-processing pipelines and applications that parse untrusted CSS via affected ffmpeg packages; limited operational impact given the minor severity and stable low exploit probability.
How an attack unfolds
An attacker sends a malformed CSS payload to any component that invokes the vulnerable parser; the validation flaw causes the parser to enter an error state resulting in a minor denial of service.
How to fix it
Upgrade ffmpeg packages on Debian 11 to 7:4.3.7-0+deb11u1, on Debian 12 to 7:5.1.5-0+deb12u1, on Debian 13 to 7:7.0.1-3, and on Ubuntu Pro 18.04 LTS to 7:3.4.11-0ubuntu0.1+esm5. Apply the updates through the platform package manager and restart dependent services.
How to confirm the fix worked
Confirm installed package versions match the listed fixed releases; re-test CSS parsing with known malformed inputs to verify the denial-of-service condition no longer occurs.
Typical attack path
- Locate an endpoint or workflow that accepts or processes CSS content
- Craft a minimal malformed CSS input that triggers the validation failure
- Submit the payload to the parser
- Observe service or thread degradation or restart
How to detect it
Review application and system logs for repeated CSS parsing failures or abrupt process restarts around the time of suspected exposure; correlate with ffmpeg process exit codes indicating abnormal termination.
What your security team should do
- Schedule package upgrades during the next maintenance window
- Monitor EPSS and exploit maturity indicators for any upward trend
- Review downstream dependents that embed or call ffmpeg CSS parsing routines
The record
@adobe/css-tools version 4.3.0 and earlier are affected by an Improper Input Validation vulnerability that could result in a minor denial of service while attempting to parse CSS. Exploitation of this issue does not require user interaction or privileges.
Affected packages
| Ecosystem | Package | Introduced | Fixed |
|---|---|---|---|
| npm | @adobe/css-tools | 0 | 4.3.1 |
| SUSE:Linux Enterprise Micro 5.4 | cockpit-wicked | 0 | 4.5-150400.3.3.1 |
| SUSE:Linux Enterprise Micro 5.5 | cockpit-wicked | 0 | 5~git8.c06c55b-150500.3.3.1 |