CVE-2022-37706
High · 7.8CVSS
7.8
EPSS
6.0%
Published
Dec 25, 2022
CISA due date
—
Cloudanix analysis
A tool on the computer lets someone already logged in take complete control of the machine.
- Exploitation
- Local Privilege
- Attacker needs
- Local User
- Complexity
- Low
- Impact
- Full Compromise
- Component
- Application
- Class
- Privilege Escalation
- Remediation
- Upgrade
- Effort
- Medium
- Patch risk
- Low
What it actually does
The vulnerability allows a local user to escalate privileges because a setuid root binary mishandles pathnames beginning with a /dev/.. substring.
Why it matters to the business
Local attackers can obtain full root control on affected systems, enabling data theft, persistence, and further lateral movement across the environment.
How an attack unfolds
An attacker with a local shell invokes the vulnerable setuid binary using a crafted pathname starting with /dev/.. to bypass restrictions and execute arbitrary code as root.
How to fix it
Upgrade all affected packages to the listed fixed versions including qemu (Debian:11) fixed in 2.0.0+dfsg-1, qemu (Debian:12) fixed in 2.0.0+dfsg-1, qemu (Debian:13) fixed in 2.0.0+dfsg-1, and qemu (Ubuntu:14.04:LTS) fixed in 2.0.0~rc1+dfsg-0ubuntu3.
How to confirm the fix worked
Confirm installed package versions match or exceed the fixed releases and verify that the binary rejects or safely handles /dev/.. pathnames.
Typical attack path
- Gain an initial local shell on the target system
- Locate the setuid root binary
- Construct a malicious pathname beginning with /dev/..
- Execute the binary with the crafted path to spawn a root shell
How to detect it
Review authentication and process execution logs for invocations of the vulnerable binary accompanied by unusual pathnames containing /dev/.. ; inspect for sudden root-owned processes spawned from non-root sessions.
What your security team should do
- Apply the listed package updates on all affected systems without delay
- Audit and remove unnecessary setuid binaries
- Enable monitoring for local privilege escalation attempts in system logs
The record
enlightenment_sys in Enlightenment before 0.25.4 allows local users to gain privileges because it is setuid root, and the system library function mishandles pathnames that begin with a /dev/.. substring.
Affected packages
| Ecosystem | Package | Introduced | Fixed |
|---|---|---|---|
| Debian:10 | e17 | 0 | 0.22.4-2+deb10u1 |
| Debian:11 | e17 | 0 | 0.24.2-8+deb11u1 |
| Debian:12 | e17 | 0 | 0.25.4-1 |
| Debian:13 | e17 | 0 | 0.25.4-1 |
| Mageia:8 | enlightenment | 0 | 0.24.2-2.1.mga8 |
| SUSE:Package Hub 15 SP4 | enlightenment | 0 | 0.25.4-bp154.4.3.1 |
| Ubuntu:16.04:LTS | e17 | 0 | No fix |
| Ubuntu:18.04:LTS | e17 | 0 | No fix |
| Ubuntu:20.04:LTS | e17 | 0 | No fix |
| Ubuntu:22.04:LTS | e17 | 0 | No fix |
| Ubuntu:24.04:LTS | e17 | 0 | No fix |
| Ubuntu:24.10 | e17 | 0 | No fix |
| Ubuntu:25.04 | e17 | 0 | No fix |
| Ubuntu:25.10 | e17 | 0 | No fix |
| Ubuntu:Pro:16.04:LTS | e17 | 0 | No fix |
| Ubuntu:Pro:18.04:LTS | e17 | 0 | No fix |
| Ubuntu:Pro:20.04:LTS | e17 | 0 | No fix |
| openSUSE:Leap 15.4 | enlightenment | 0 | 0.25.4-bp154.4.3.1 |
Related vulnerabilities
- CVE-2026-63339 IXP Manager is a full-stack web application for managing Internet Exchange Points. CWE-269
- CVE-2026-62990 Shopper is a Headless e-commerce Admin Panel. CWE-269
- CVE-2026-61850 Kargo manages and automates the promotion of software artifacts. CWE-269
- CVE-2026-118205 The Essential Addons for Elementor – Popular Elementor Templates & Widgets plugin for… CWE-269
- CVE-2026-105894 The Ak Framework plugin for WordPress, included in the Newsy - Viral News & Magazine… CWE-269
- CVE-2026-101213 Dell OpenManage Enterprise, versions prior to 4.8.0, contains an Improper Privilege… CWE-269
- CVE-2026-59386 A SpaceSupporter could improperly modify an application's start command and… CWE-269
- CVE-2026-113616 The LogixFast Auth WordPress plugin before 1.0.4 does not deliver its password-reset… CWE-269