Cloudanix VulnDB

CVE-2022-2175

High · 7.8

CVSS

7.8

EPSS

1.3%

Published

Jun 23, 2022

CISA due date

—

Cloudanix analysis

Monitor only SSVC: Track

A problem in the Vim text editor can let someone cause it to crash or leak data in memory if a user opens a specially crafted file.

Exploit Available
Exploitation
Requires User Interaction
Attacker needs
User Interaction
Complexity
Moderate
Impact
Full Compromise
Component
Application
Class
Memory Corruption
Remediation
Upgrade
Effort
Medium
Patch risk
Low

What it actually does

Buffer over-read in Vim's file parsing logic allowing out-of-bounds memory access when processing crafted input, resulting in information disclosure or process crash.

Why it matters to the business

Developers and operators using affected Vim versions risk editor crashes or leakage of sensitive data in memory when opening untrusted files, disrupting editing workflows and potentially exposing confidential information.

How an attack unfolds

An attacker crafts a malicious file that triggers the buffer over-read during Vim's parsing routines. The victim opens the file locally in a vulnerable Vim instance (user interaction required), causing the over-read to execute and leak memory contents or crash the editor.

How to fix it

Upgrade vim/vim to the fixed commit 98056533b96b6b5d8849641de93185dd7bcadc44 or later. Rebuild from source or obtain a patched package for the distribution in use.

How to confirm the fix worked

Verify Vim reports the fixed commit or version 8.2+. Test opening known trigger files in a controlled environment and confirm absence of crashes or unexpected memory access.

Typical attack path

  1. Craft a file designed to trigger buffer over-read in Vim parsing
  2. Deliver the file to the target via email, download, or shared storage
  3. Victim opens the file using a vulnerable Vim binary
  4. Vim processes the file and performs the out-of-bounds read
  5. Attacker observes crash or obtains leaked memory data

How to detect it

Monitor system logs and Vim crash reports for segmentation faults or memory errors during file open operations; review process execution history for unexpected Vim invocations on suspicious files.

What your security team should do

  • Prioritize updating all Vim installations to the fixed commit
  • Restrict opening of untrusted files in Vim until patched
  • Include Vim in regular software inventory and patch cycles

The record

Buffer Over-read in GitHub repository vim/vim prior to 8.2.

Affected packages

Ecosystem Package Introduced Fixed
Debian:11 vim 0 No fix
Debian:12 vim 0 2:9.0.0135-1
Debian:13 vim 0 2:9.0.0135-1
Mageia:8 vim 0 9.0.828-1.mga8
SUSE:Enterprise Storage 6 vim 0 9.0.0313-150000.5.25.1
SUSE:Enterprise Storage 7 vim 0 9.0.0313-150000.5.25.1
SUSE:Linux Enterprise High Performance Computing 15 SP1-ESPOS vim 0 9.0.0313-150000.5.25.1
SUSE:Linux Enterprise High Performance Computing 15 SP1-LTSS vim 0 9.0.0313-150000.5.25.1
SUSE:Linux Enterprise High Performance Computing 15 SP2-ESPOS vim 0 9.0.0313-150000.5.25.1
SUSE:Linux Enterprise High Performance Computing 15 SP2-LTSS vim 0 9.0.0313-150000.5.25.1
SUSE:Linux Enterprise High Performance Computing 15-ESPOS vim 0 9.0.0313-150000.5.25.1
SUSE:Linux Enterprise High Performance Computing 15-LTSS vim 0 9.0.0313-150000.5.25.1
SUSE:Linux Enterprise Micro 5.1 vim 0 9.0.0313-150000.5.25.1
SUSE:Linux Enterprise Micro 5.2 vim 0 9.0.0313-150000.5.25.1
SUSE:Linux Enterprise Module for Basesystem 15 SP3 vim 0 9.0.0313-150000.5.25.1
SUSE:Linux Enterprise Module for Basesystem 15 SP4 vim 0 9.0.0313-150000.5.25.1
SUSE:Linux Enterprise Module for Desktop Applications 15 SP3 vim 0 9.0.0313-150000.5.25.1
SUSE:Linux Enterprise Module for Desktop Applications 15 SP4 vim 0 9.0.0313-150000.5.25.1
SUSE:Linux Enterprise Server 12 SP2-BCL vim 0 9.0.0814-17.9.1
SUSE:Linux Enterprise Server 12 SP3-BCL vim 0 9.0.0814-17.9.1
SUSE:Linux Enterprise Server 12 SP4-LTSS vim 0 9.0.0814-17.9.1
SUSE:Linux Enterprise Server 12 SP5 vim 0 9.0.0814-17.9.1
SUSE:Linux Enterprise Server 15 SP1-BCL vim 0 9.0.0313-150000.5.25.1
SUSE:Linux Enterprise Server 15 SP1-LTSS vim 0 9.0.0313-150000.5.25.1
SUSE:Linux Enterprise Server 15 SP2-BCL vim 0 9.0.0313-150000.5.25.1
SUSE:Linux Enterprise Server 15 SP2-LTSS vim 0 9.0.0313-150000.5.25.1
SUSE:Linux Enterprise Server 15-LTSS vim 0 9.0.0313-150000.5.25.1
SUSE:Linux Enterprise Server for SAP Applications 12 SP4 vim 0 9.0.0814-17.9.1
SUSE:Linux Enterprise Server for SAP Applications 12 SP5 vim 0 9.0.0814-17.9.1
SUSE:Linux Enterprise Server for SAP Applications 15 vim 0 9.0.0313-150000.5.25.1
SUSE:Linux Enterprise Server for SAP Applications 15 SP1 vim 0 9.0.0313-150000.5.25.1
SUSE:Linux Enterprise Server for SAP Applications 15 SP2 vim 0 9.0.0313-150000.5.25.1
SUSE:Manager Proxy 4.1 vim 0 9.0.0313-150000.5.25.1
SUSE:Manager Retail Branch Server 4.1 vim 0 9.0.0313-150000.5.25.1
SUSE:Manager Server 4.1 vim 0 9.0.0313-150000.5.25.1
SUSE:OpenStack Cloud 9 vim 0 9.0.0814-17.9.1
SUSE:OpenStack Cloud Crowbar 9 vim 0 9.0.0814-17.9.1
Ubuntu:18.04:LTS vim 0 2:8.0.1453-1ubuntu1.12
Ubuntu:20.04:LTS vim 0 2:8.1.2269-1ubuntu5.13
Ubuntu:22.04:LTS vim 0 2:8.2.3995-1ubuntu2.5
Ubuntu:Pro:14.04:LTS vim 0 2:7.4.052-1ubuntu3.1+esm8
Ubuntu:Pro:16.04:LTS vim 0 2:7.4.1689-3ubuntu1.5+esm13
openSUSE:Leap 15.3 vim 0 9.0.0313-150000.5.25.1
openSUSE:Leap 15.4 vim 0 9.0.0313-150000.5.25.1
openSUSE:Leap Micro 5.2 vim 0 9.0.0313-150000.5.25.1
openSUSE:Tumbleweed vim 0 9.0.0453-2.1

Related vulnerabilities