Cloudanix VulnDB

CVE-2022-21488

Low · 3.8

CVSS

3.8

EPSS

0.4%

Published

Apr 19, 2022

CISA due date

—

Cloudanix analysis

Schedule a fix SSVC: Track

A regular user logged into the computer running the virtual machine software can change a small amount of its settings, which might affect other programs on that computer.

Exploitation
Local Privilege
Attacker needs
Low Privilege
Complexity
Low
Impact
Data Tampering
Component
Application
Class
Privilege Escalation
Remediation
Upgrade
Effort
Medium
Patch risk
Low

What it actually does

Allows a low-privileged local attacker with access to the host where VirtualBox runs to perform unauthorized modifications to a limited set of VirtualBox data, with the flaw crossing scope boundaries to affect other products.

Why it matters to the business

Low-privileged users on the virtualization host can alter limited configuration or metadata, potentially affecting guest integrity and downstream systems without requiring network access or elevated rights.

How an attack unfolds

An attacker logs into the host system with a low-privileged account, triggers the core component flaw through normal VirtualBox interaction, and performs unauthorized data modifications that propagate to other products due to the scope change.

How to fix it

Upgrade Oracle VM VirtualBox to version 6.1.34 or later on all affected hosts.

How to confirm the fix worked

Verify installed VirtualBox version is 6.1.34 or newer; confirm no residual vulnerable binaries remain and test that low-privileged host accounts cannot modify protected data.

Typical attack path

  1. Obtain low-privileged local logon to the virtualization host
  2. Interact with VirtualBox core component to trigger the flaw
  3. Perform unauthorized insert/update/delete operations on accessible data
  4. Leverage scope change to impact additional products or components

How to detect it

Review host authentication and process execution logs for low-privileged accounts launching VirtualBox shortly before unexpected data changes; examine VirtualBox log and configuration files for anomalous modifications.

What your security team should do

  • Immediately inventory all VirtualBox installations and schedule upgrade to 6.1.34+
  • Restrict host logons to only trusted administrators where possible
  • Monitor host audit logs for unexpected VirtualBox data modification attempts

The record

Vulnerability in the Oracle VM VirtualBox product of Oracle Virtualization (component: Core). The supported version that is affected is Prior to 6.1.34. Easily exploitable vulnerability allows low privileged attacker with logon to the infrastructure where Oracle VM VirtualBox executes to compromise Oracle VM VirtualBox. While the vulnerability is in Oracle VM VirtualBox, attacks may significantly impact additional products (scope change). Successful attacks of this vulnerability can result in unauthorized update, insert or delete access to some of Oracle VM VirtualBox accessible data. CVSS 3.1 Base Score 3.8 (Integrity impacts). CVSS Vector: (CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:N/I:L/A:N).

Affected packages

Ecosystem Package Introduced Fixed
Mageia:8 kmod-virtualbox 0 6.1.34-1.2.mga8
Mageia:8 virtualbox 0 6.1.34-1.2.mga8
Ubuntu:16.04:LTS virtualbox 0 No fix
Ubuntu:18.04:LTS virtualbox 0 No fix
Ubuntu:20.04:LTS virtualbox 0 No fix
Ubuntu:20.04:LTS vm 0 No fix
Ubuntu:22.04:LTS virtualbox 0 No fix
Ubuntu:22.04:LTS vm 0 No fix
Ubuntu:24.04:LTS virtualbox 0 No fix
Ubuntu:24.04:LTS vm 0 No fix
Ubuntu:24.10 virtualbox 0 No fix
Ubuntu:24.10 vm 0 No fix
Ubuntu:25.04 virtualbox 0 No fix
Ubuntu:25.10 virtualbox 0 No fix
Ubuntu:Pro:16.04:LTS virtualbox 0 No fix
Ubuntu:Pro:16.04:LTS vm 0 No fix
Ubuntu:Pro:18.04:LTS virtualbox 0 No fix
Ubuntu:Pro:18.04:LTS vm 0 No fix
Ubuntu:Pro:20.04:LTS virtualbox 0 No fix
openSUSE:Leap 15.4 virtualbox 0 6.1.36-lp154.2.7.1
openSUSE:Leap 15.4 virtualbox-kmp 0 6.1.36-lp154.2.7.1

Related vulnerabilities