CVE-2020-6923
Medium · 5.7CVSS
5.7
EPSS
0.3%
Published
Dec 19, 2024
CISA due date
—
Cloudanix analysis
A flaw in certain printing software could let nearby attackers crash programs and cause downtime until the software is updated.
- Exploitation
- Requires User Interaction
- Attacker needs
- User Interaction
- Complexity
- Moderate
- Impact
- Denial Of Service
- Component
- Application
- Class
- Buffer Overflow
- Remediation
- Upgrade
- Effort
- Medium
- Patch risk
- Low
What it actually does
Memory buffer overflow condition allowing high availability impact through application crashes when processing crafted input over adjacent network.
Why it matters to the business
Potential service disruption on affected Linux systems running the vulnerable software, requiring urgent patching on legacy Ubuntu 14.04 deployments despite low exploit probability.
How an attack unfolds
An attacker on the same network crafts and delivers malicious data to trigger the buffer overflow in the HPLIP component, resulting in denial of service without requiring authentication or user interaction beyond initial exposure.
How to fix it
Upgrade chromium-browser on Ubuntu 14.04 LTS to version 53.0.2785.143-0ubuntu0.14.04.1.1142 or later; apply equivalent patches for HPLIP where the buffer overflow originates.
How to confirm the fix worked
Confirm installed package versions meet or exceed the fixed releases and perform functional testing to ensure buffer handling no longer triggers crashes.
Typical attack path
- Scan for exposed instances of the vulnerable HPLIP software on the local network
- Craft a malicious payload designed to overflow the memory buffer
- Transmit the payload via adjacent network vectors
- Trigger the overflow to cause application crash or further impact
How to detect it
Review system and application logs for unexpected crashes or memory-related errors around HPLIP processes; correlate with network traffic from untrusted adjacent hosts.
What your security team should do
- Apply the listed fixed versions immediately on all affected Ubuntu 14.04 systems
- Restrict network exposure of printing services until patched
- Monitor EPSS trends and re-evaluate if exploit maturity increases
The record
The HP Linux Imaging and Printing (HPLIP) software may potentially be affected by memory buffer overflow.
Affected packages
| Ecosystem | Package | Introduced | Fixed |
|---|---|---|---|
| Debian:11 | hplip | 0 | 3.20.9+dfsg0-3 |
| Debian:12 | hplip | 0 | 3.20.9+dfsg0-3 |
| Debian:13 | hplip | 0 | 3.20.9+dfsg0-3 |
| SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS | hplip | 0 | 3.24.4-150400.3.17.1 |
| SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS | hplip | 0 | 3.24.4-150400.3.17.1 |
| SUSE:Linux Enterprise High Performance Computing 15 SP5-ESPOS | hplip | 0 | 3.24.4-150400.3.17.1 |
| SUSE:Linux Enterprise High Performance Computing 15 SP5-LTSS | hplip | 0 | 3.24.4-150400.3.17.1 |
| SUSE:Linux Enterprise Module for Basesystem 15 SP6 | hplip | 0 | 3.24.4-150600.4.6.1 |
| SUSE:Linux Enterprise Module for Desktop Applications 15 SP6 | hplip | 0 | 3.24.4-150600.4.6.1 |
| SUSE:Linux Enterprise Server 12 SP5-LTSS | hplip | 0 | 3.24.4-3.5.1 |
| SUSE:Linux Enterprise Server 15 SP4-LTSS | hplip | 0 | 3.24.4-150400.3.17.1 |
| SUSE:Linux Enterprise Server 15 SP5-LTSS | hplip | 0 | 3.24.4-150400.3.17.1 |
| SUSE:Linux Enterprise Server LTSS Extended Security 12 SP5 | hplip | 0 | 3.24.4-3.5.1 |
| SUSE:Linux Enterprise Server for SAP Applications 15 SP4 | hplip | 0 | 3.24.4-150400.3.17.1 |
| SUSE:Linux Enterprise Server for SAP Applications 15 SP5 | hplip | 0 | 3.24.4-150400.3.17.1 |
| SUSE:Manager Proxy 4.3 | hplip | 0 | 3.24.4-150400.3.17.1 |
| SUSE:Manager Server 4.3 | hplip | 0 | 3.24.4-150400.3.17.1 |
| Ubuntu:16.04:LTS | hplip | 0 | No fix |
| Ubuntu:18.04:LTS | hplip | 0 | No fix |
| Ubuntu:20.04:LTS | hplip | 0 | 3.20.3+dfsg0-2ubuntu0.1 |
| Ubuntu:22.04:LTS | hplip | 0 | 3.21.12+dfsg0-1 |
| Ubuntu:24.04:LTS | hplip | 0 | 3.23.12+dfsg0-0ubuntu5 |
| Ubuntu:24.10 | hplip | 0 | 3.24.4+dfsg0-0ubuntu3 |
| Ubuntu:Pro:16.04:LTS | hplip | 0 | No fix |
| Ubuntu:Pro:18.04:LTS | hplip | 0 | No fix |
| openSUSE:Leap 15.6 | hplip | 0 | 3.24.4-150600.4.6.1 |
| openSUSE:Tumbleweed | hplip | 0 | 3.24.4-4.1 |
Related vulnerabilities
- CVE-2015-0839 The hp-plugin utility in HP Linux Imaging and Printing (HPLIP) makes it easier for… Also affects hplip
- CVE-2011-2697 foomatic-rip-hplip in HP Linux Imaging and Printing (HPLIP) 3.11.5 allows remote… Also affects hplip
- CVE-2010-4267 Stack-based buffer overflow in the hpmud_get_pml function in io/hpmud/pml.c in… Also affects hplip
- CVE-2007-5208 hpssd in Hewlett-Packard Linux Imaging and Printing Project (hplip) 1.x and 2.x before… Also affects hplip
- CVE-2026-8632 A potential security vulnerability has been identified in the HP Linux Imaging and… Also affects hplip
- CVE-2026-8631 A potential security vulnerability has been identified in the HP Linux Imaging and… Also affects hplip
- CVE-2026-112108 A vulnerability was determined in ztxz16 fastllm up to 0.1.8.2. CWE-120
- CVE-2026-90804 A vulnerability was detected in GNU Binutils 2.47. CWE-120