Cloudanix VulnDB

CVE-2020-1968

Low · 3.7

CVSS

3.7

EPSS

4.9%

Published

Sep 9, 2020

CISA due date

—

Cloudanix analysis

Monitor only SSVC: Track

An outdated encryption library used in some older systems could allow attackers to read supposedly private network traffic if the same secret was reused, but the problem only exists in very old unsupported software that should be replaced.

Exploitation
Remote Unauthenticated
Attacker needs
None
Complexity
High
Impact
Data Exposure
Component
Library
Class
Cryptographic Weakness
Remediation
Upgrade
Effort
Low
Patch risk
Low

What it actually does

Allows computation of TLS pre-master secret when a Diffie-Hellman secret is reused across multiple connections using DH-based ciphersuites, enabling decryption of traffic; limited to OpenSSL 1.0.2 and does not affect ECDH or later branches.

Why it matters to the business

Outdated cryptographic libraries in legacy systems create risk of passive eavesdropping on encrypted sessions; because the affected branch is unsupported, organizations running it face extended exposure windows and potential compliance issues until migration completes.

How an attack unfolds

An attacker captures multiple TLS handshakes that reuse the same DH secret, then performs offline mathematical operations permitted by the protocol flaw to recover the pre-master secret and decrypt all subsequent traffic on those connections.

How to fix it

Upgrade all instances of OpenSSL 1.0.2 to version 1.0.2w or migrate to a supported branch such as 1.1.1; disable static DH ciphersuites in configurations where upgrade is delayed.

How to confirm the fix worked

Inventory OpenSSL binaries and libraries for versions 1.0.2 through 1.0.2v; confirm upgrade to 1.0.2w or newer; review configuration to ensure DH ciphersuites are not configured with static or reused secrets.

Typical attack path

  1. Identify servers advertising DH ciphersuites and reusing DH values across sessions
  2. Capture multiple client and server hello and key-exchange messages
  3. Execute the Raccoon computation to derive the pre-master secret
  4. Decrypt recorded or live TLS sessions to obtain plaintext data

How to detect it

Search system package inventories, application logs, and process listings for OpenSSL versions 1.0.2 through 1.0.2v; inspect TLS configuration files and handshake captures for repeated use of the same DH parameters.

What your security team should do

  • Prioritize replacement of all OpenSSL 1.0.2 deployments with supported releases
  • Scan configurations for enabled DH ciphersuites and remove them where feasible
  • Add cryptographic library version checks to asset inventory and vulnerability scanning routines
  • Review and update TLS policies to favor ECDHE suites exclusively

The record

The Raccoon attack exploits a flaw in the TLS specification which can lead to an attacker being able to compute the pre-master secret in connections which have used a Diffie-Hellman (DH) based ciphersuite. In such a case this would result in the attacker being able to eavesdrop on all encrypted communications sent over that TLS connection. The attack can only be exploited if an implementation re-uses a DH secret across multiple TLS connections. Note that this issue only impacts DH ciphersuites and not ECDH ciphersuites. This issue affects OpenSSL 1.0.2 which is out of support and no longer receiving public updates. OpenSSL 1.1.1 is not vulnerable to this issue. Fixed in OpenSSL 1.0.2w (Affected 1.0.2-1.0.2v).

Affected packages

Ecosystem Package Introduced Fixed
Debian:11 openssl 0 1.1.0c-1
Debian:12 openssl 0 1.1.0c-1
Debian:13 openssl 0 1.1.0c-1
Debian:9 openssl1.0 0 1.0.2u-1~deb9u2
Mageia:7 compat-openssl10 0 1.0.2u-1.1.mga7
SUSE:Linux Enterprise Module for Legacy 12 compat-openssl098 0 0.9.8j-106.21.1
SUSE:Linux Enterprise Point of Sale 11 SP3 openssl 0 0.9.8j-0.106.34.1
SUSE:Linux Enterprise Server 11 SP4-LTSS openssl 0 0.9.8j-0.106.34.1
SUSE:Linux Enterprise Server 11-SECURITY openssl1 0 1.0.1g-0.58.27.2
SUSE:Linux Enterprise Server for SAP Applications 12 SP2 compat-openssl098 0 0.9.8j-106.21.1
SUSE:Linux Enterprise Server for SAP Applications 12 SP3 compat-openssl098 0 0.9.8j-106.21.1
SUSE:Linux Enterprise Server for SAP Applications 12 SP4 compat-openssl098 0 0.9.8j-106.21.1
SUSE:Linux Enterprise Server for SAP Applications 12 SP5 compat-openssl098 0 0.9.8j-106.21.1
Ubuntu:16.04:LTS openssl 0 1.0.2g-1ubuntu4.17
Ubuntu:18.04:LTS openssl 0 1.1.1-1ubuntu2.1~18.04.6
Ubuntu:18.04:LTS openssl1.0 0 1.0.2n-1ubuntu5.4
Ubuntu:20.04:LTS openssl 0 1.1.1f-1ubuntu2
Ubuntu:Pro:14.04:LTS openssl 0 No fix
Ubuntu:Pro:14.04:LTS openssl 0 1.0.1f-1ubuntu2.27+esm10
Ubuntu:Pro:16.04:LTS edk2 0 No fix
Ubuntu:Pro:FIPS:16.04:LTS openssl 0 No fix
Ubuntu:Pro:FIPS:16.04:LTS openssl 0 1.0.2g-1ubuntu4.fips.4.17.1
conan openssl 1.0.2 No fix

Related vulnerabilities