Cloudanix VulnDB

CVE-2020-1967

High · 7.5

CVSS

7.5

EPSS

53.3%

Published

Apr 21, 2020

CISA due date

—

The record

Server or client applications that call the SSL_check_chain() function during or after a TLS 1.3 handshake may crash due to a NULL pointer dereference as a result of incorrect handling of the "signature_algorithms_cert" TLS extension. The crash occurs if an invalid or unrecognised signature algorithm is received from the peer. This could be exploited by a malicious peer in a Denial of Service attack. OpenSSL version 1.1.1d, 1.1.1e, and 1.1.1f are affected by this issue. This issue did not affect OpenSSL versions prior to 1.1.1d. Fixed in OpenSSL 1.1.1g (Affected 1.1.1d-1.1.1f).

Affected packages

Ecosystem Package Introduced Fixed
crates.io openssl-src 111.6.0 111.9.0
Alpine:v3.10 openssl 0 1.1.1g-r0
Alpine:v3.11 openssl 0 1.1.1g-r0
Alpine:v3.12 openssl 0 1.1.1g-r0
Alpine:v3.13 openssl 0 1.1.1g-r0
Alpine:v3.14 openssl 0 1.1.1g-r0
Alpine:v3.15 openssl 0 1.1.1g-r0
Alpine:v3.15 openssl3 0 1.1.1g-r0
Alpine:v3.16 openssl 0 1.1.1g-r0
Alpine:v3.16 openssl3 0 1.1.1g-r0
Alpine:v3.17 openssl 0 1.1.1g-r0
Alpine:v3.18 openssl 0 1.1.1g-r0
Alpine:v3.19 openssl 0 1.1.1g-r0
Alpine:v3.20 openssl 0 1.1.1g-r0
Alpine:v3.21 openssl 0 1.1.1g-r0
Alpine:v3.22 openssl 0 1.1.1g-r0
Alpine:v3.9 openssl 0 1.1.1g-r0
Chainguard mysql-8.0 0 8.0.38-r0
Chainguard mysql-8.0-bitnami-compat 0 8.0.38-r0
Chainguard mysql-8.0-client 0 8.0.38-r0
Chainguard mysql-8.0-dev 0 8.0.38-r0
Chainguard mysql-8.0-iamguarded-compat 0 8.0.38-r0
Chainguard mysql-8.0-oci-entrypoint 0 8.0.38-r0
Chainguard mysql-8.0-oci-entrypoint-compat 0 8.0.38-r0
Debian:10 openssl 0 1.1.1d-0+deb10u3
Debian:11 openssl 0 1.1.1g-1
Debian:12 openssl 0 1.1.1g-1
Debian:13 openssl 0 1.1.1g-1
SUSE:Linux Enterprise Module for Development Tools 15 SP1 rust 0 1.43.1-12.1
SUSE:Linux Enterprise Module for Development Tools 15 SP2 rust 0 1.43.1-12.1
SUSE:Linux Enterprise Server 12 SP4 openssl-1_1 0 1.1.1d-2.23.1
SUSE:Linux Enterprise Server 12 SP5 openssl-1_1 0 1.1.1d-2.23.1
SUSE:Linux Enterprise Server for SAP Applications 12 SP4 openssl-1_1 0 1.1.1d-2.23.1
SUSE:Linux Enterprise Server for SAP Applications 12 SP5 openssl-1_1 0 1.1.1d-2.23.1
SUSE:Linux Enterprise Software Development Kit 12 SP4 openssl-1_1 0 1.1.1d-2.23.1
SUSE:Linux Enterprise Software Development Kit 12 SP5 openssl-1_1 0 1.1.1d-2.23.1
Ubuntu:20.04:LTS openssl 0 1.1.1f-1ubuntu2
cargo openssl-src 111.6.0 111.9.0
conan openssl 1.1.1d No fix
openSUSE:Leap 15.1 rust 0 1.43.1-lp151.5.13.1
openSUSE:Leap 15.1 rust-cbindgen 0 0.14.1-lp151.8.2
openSUSE:Leap 15.2 rust 0 1.43.1-lp152.3.5.1
openSUSE:Leap 15.2 rust-cbindgen 0 0.14.1-lp152.2.4.1
openSUSE:Tumbleweed openssl-1_1 0 1.1.1l-1.2
openSUSE:Tumbleweed rust1.53 0 1.53.0-2.5

Related vulnerabilities