CVE-2018-5345
High · 7.8CVSS
7.8
EPSS
2.2%
Published
Jan 12, 2018
CISA due date
—
Cloudanix analysis
A problem in software that handles certain archive files can let attackers crash computers or run their own programs if someone opens a specially made file.
- Exploitation
- Requires User Interaction
- Attacker needs
- User Interaction
- Complexity
- Low
- Impact
- Full Compromise
- Component
- Library
- Class
- Memory Corruption
- Remediation
- Upgrade
- Effort
- Medium
- Patch risk
- Low
What it actually does
Stack-based buffer overflow in gcab library when parsing specially crafted CAB archives, enabling memory corruption that can lead to process crash or arbitrary code execution.
Why it matters to the business
Systems that extract or inspect CAB files on Linux distributions can be crashed or fully compromised, potentially allowing attackers to gain control of affected workstations or servers and access sensitive data.
How an attack unfolds
An attacker creates a malicious CAB file that triggers the buffer overflow during parsing; the file is delivered to a victim via email, download, or shared storage; when the victim or an automated process opens the archive with gcab or an application using the library, the overflow occurs and attacker-controlled code executes.
How to fix it
Upgrade gcab to a version newer than 0.7.4 on all affected distributions; rebuild or redeploy any dependent packages that statically link the library; replace gcab usage with alternative archive handlers where feasible until updates are applied.
How to confirm the fix worked
Verify installed gcab version is greater than 0.7.4; test parsing of known-good and known-malicious CAB samples in a sandbox to confirm absence of crashes or unexpected behavior; review package manifests for rebuilt dependencies.
Typical attack path
- Craft a CAB archive containing a payload that overflows a stack buffer in gcab
- Deliver the malicious file to the target environment
- Induce the victim or automated process to open or extract the archive
- Trigger the overflow to achieve code execution or denial of service
How to detect it
Search system and application logs for gcab process crashes or segmentation faults occurring during CAB extraction; inspect file-access logs for unexpected .cab files opened by users or services; review security telemetry for post-crash process creation or privilege escalation attempts originating from archive-handling binaries.
What your security team should do
- Prioritize patching gcab on all Linux systems that process CAB files
- Disable or restrict gcab in environments where CAB handling is unnecessary
- Monitor for new fixed packages from distribution vendors and apply them promptly
- Add archive-handling tools to the list of high-risk components requiring regular inventory
The record
A stack-based buffer overflow within GNOME gcab through 0.7.4 can be exploited by malicious attackers to cause a crash or, potentially, execute arbitrary code via a crafted .cab file.
Affected packages
| Ecosystem | Package | Introduced | Fixed |
|---|---|---|---|
| Debian:11 | gcab | 0 | 0.7-7 |
| Debian:12 | gcab | 0 | 0.7-7 |
| Debian:13 | gcab | 0 | 0.7-7 |
| Debian:9 | gcab | 0 | 0.7-2+deb9u1 |
| Mageia:5 | gcab | 0 | 0.4-6.1.mga5 |
| Mageia:6 | gcab | 0 | 0.7-1.1.mga6 |
| Red Hat:enterprise_linux:7::client | gcab | 0 | 0:0.7-4.el7_4 |
| Red Hat:enterprise_linux:7::client | gcab-debuginfo | 0 | 0:0.7-4.el7_4 |
| Red Hat:enterprise_linux:7::client | libgcab1 | 0 | 0:0.7-4.el7_4 |
| Red Hat:enterprise_linux:7::client | libgcab1-devel | 0 | 0:0.7-4.el7_4 |
| Red Hat:enterprise_linux:7::computenode | gcab | 0 | 0:0.7-4.el7_4 |
| Red Hat:enterprise_linux:7::computenode | gcab-debuginfo | 0 | 0:0.7-4.el7_4 |
| Red Hat:enterprise_linux:7::computenode | libgcab1 | 0 | 0:0.7-4.el7_4 |
| Red Hat:enterprise_linux:7::computenode | libgcab1-devel | 0 | 0:0.7-4.el7_4 |
| Red Hat:enterprise_linux:7::server | gcab | 0 | 0:0.7-4.el7_4 |
| Red Hat:enterprise_linux:7::server | gcab-debuginfo | 0 | 0:0.7-4.el7_4 |
| Red Hat:enterprise_linux:7::server | libgcab1 | 0 | 0:0.7-4.el7_4 |
| Red Hat:enterprise_linux:7::server | libgcab1-devel | 0 | 0:0.7-4.el7_4 |
| Red Hat:enterprise_linux:7::workstation | gcab | 0 | 0:0.7-4.el7_4 |
| Red Hat:enterprise_linux:7::workstation | gcab-debuginfo | 0 | 0:0.7-4.el7_4 |
| Red Hat:enterprise_linux:7::workstation | libgcab1 | 0 | 0:0.7-4.el7_4 |
| Red Hat:enterprise_linux:7::workstation | libgcab1-devel | 0 | 0:0.7-4.el7_4 |
| Ubuntu:16.04:LTS | gcab | 0 | 0.7-1ubuntu0.1 |
| openSUSE:Tumbleweed | gcab | 0 | 1.4-2.9 |
Related vulnerabilities
- CVE-2026-111497 A buffer overflow vulnerability in the Brotli decoder (c/dec/decode.c) in Google Brotli… CWE-787
- CVE-2026-112397 Pillow is a Python imaging library. CWE-787
- CVE-2026-112059 libLAS through 1.8.1 contains a heap out-of-bounds write vulnerability in the point… CWE-787
- CVE-2026-89088 A flaw was found in parted. CWE-787
- CVE-2026-89085 A flaw was found in parted. CWE-787
- CVE-2026-85746 MariaDB server is a community developed fork of MySQL server. CWE-787
- CVE-2026-107815 MariaDB server is a community developed fork of MySQL server. CWE-787
- CVE-2026-56851 The Nickname profile can panic with an out-of-bounds slice error when transforming… CWE-787