CVE-2017-5495
High · 7.5CVSS
7.5
EPSS
18.8%
Published
Jan 24, 2017
CISA due date
—
The record
All versions of Quagga, 0.93 through 1.1.0, are vulnerable to an unbounded memory allocation in the telnet 'vty' CLI, leading to a Denial-of-Service of Quagga daemons, or even the entire host. When Quagga daemons are configured with their telnet CLI enabled, anyone who can connect to the TCP ports can trigger this vulnerability, prior to authentication. Most distributions restrict the Quagga telnet interface to local access only by default. The Quagga telnet interface 'vty' input buffer grows automatically, without bound, so long as a newline is not entered. This allows an attacker to cause the Quagga daemon to allocate unbounded memory by sending very long strings without a newline. Eventually the daemon is terminated by the system, or the system itself runs out of memory. This is fixed in Quagga 1.1.1 and Free Range Routing (FRR) Protocol Suite 2017-01-10.
Affected packages
| Ecosystem | Package | Introduced | Fixed |
|---|---|---|---|
| Alpine:v3.10 | quagga | 0 | 1.1.1-r0 |
| Alpine:v3.11 | quagga | 0 | 1.1.1-r0 |
| Alpine:v3.12 | quagga | 0 | 1.1.1-r0 |
| Alpine:v3.13 | quagga | 0 | 1.1.1-r0 |
| Alpine:v3.14 | quagga | 0 | 1.1.1-r0 |
| Alpine:v3.15 | quagga | 0 | 1.1.1-r0 |
| Alpine:v3.16 | quagga | 0 | 1.1.1-r0 |
| Alpine:v3.17 | quagga | 0 | 1.1.1-r0 |
| Alpine:v3.18 | quagga | 0 | 1.1.1-r0 |
| Alpine:v3.19 | quagga | 0 | 1.1.1-r0 |
| Alpine:v3.20 | quagga | 0 | 1.1.1-r0 |
| Alpine:v3.21 | quagga | 0 | 1.1.1-r0 |
| Alpine:v3.22 | quagga | 0 | 1.1.1-r0 |
| Alpine:v3.5 | quagga | 0 | 1.1.1-r0 |
| Alpine:v3.6 | quagga | 0 | 1.1.1-r0 |
| Alpine:v3.7 | quagga | 0 | 1.1.1-r0 |
| Alpine:v3.8 | quagga | 0 | 1.1.1-r0 |
| Alpine:v3.9 | quagga | 0 | 1.1.1-r0 |
| Mageia:5 | quagga | 0 | 0.99.22.4-4.4.mga5 |
| Red Hat:enterprise_linux:6::server | quagga | 0 | 0:0.99.15-14.el6 |
| Red Hat:enterprise_linux:6::server | quagga-contrib | 0 | 0:0.99.15-14.el6 |
| Red Hat:enterprise_linux:6::server | quagga-debuginfo | 0 | 0:0.99.15-14.el6 |
| Red Hat:enterprise_linux:6::server | quagga-devel | 0 | 0:0.99.15-14.el6 |
| Red Hat:enterprise_linux:6::workstation | quagga | 0 | 0:0.99.15-14.el6 |
| Red Hat:enterprise_linux:6::workstation | quagga-contrib | 0 | 0:0.99.15-14.el6 |
| Red Hat:enterprise_linux:6::workstation | quagga-debuginfo | 0 | 0:0.99.15-14.el6 |
| Red Hat:enterprise_linux:6::workstation | quagga-devel | 0 | 0:0.99.15-14.el6 |
| SUSE:Linux Enterprise Point of Sale 11 SP3 | quagga | 0 | 0.99.15-0.30.3.1 |
| SUSE:Linux Enterprise Server 11 SP3-LTSS | quagga | 0 | 0.99.15-0.30.3.1 |
| SUSE:Linux Enterprise Server 11 SP3-TERADATA | quagga | 0 | 0.99.15-0.30.3.1 |
| SUSE:Linux Enterprise Server 11 SP4 | quagga | 0 | 0.99.15-0.30.3.1 |
| SUSE:Linux Enterprise Server 12 SP1-LTSS | quagga | 0 | 0.99.22.1-16.4.1 |
| SUSE:Linux Enterprise Server 12 SP2 | quagga | 0 | 1.1.1-17.3.3 |
| SUSE:Linux Enterprise Server 12 SP3 | quagga | 0 | 1.1.1-17.3.3 |
| SUSE:Linux Enterprise Server 12-LTSS | quagga | 0 | 0.99.22.1-16.4.1 |
| SUSE:Linux Enterprise Server for Raspberry Pi 12 SP2 | quagga | 0 | 1.1.1-17.3.3 |
| SUSE:Linux Enterprise Server for SAP Applications 11 SP4 | quagga | 0 | 0.99.15-0.30.3.1 |
| SUSE:Linux Enterprise Server for SAP Applications 12 SP1 | quagga | 0 | 0.99.22.1-16.4.1 |
| SUSE:Linux Enterprise Server for SAP Applications 12 SP2 | quagga | 0 | 1.1.1-17.3.3 |
| SUSE:Linux Enterprise Server for SAP Applications 12 SP3 | quagga | 0 | 1.1.1-17.3.3 |
| SUSE:Linux Enterprise Software Development Kit 11 SP4 | quagga | 0 | 0.99.15-0.30.3.1 |
| SUSE:Linux Enterprise Software Development Kit 12 SP2 | quagga | 0 | 1.1.1-17.3.3 |
| SUSE:Linux Enterprise Software Development Kit 12 SP3 | quagga | 0 | 1.1.1-17.3.3 |
| SUSE:OpenStack Cloud 6 | quagga | 0 | 0.99.22.1-16.4.1 |
| Ubuntu:14.04:LTS | quagga | 0 | 0.99.22.4-3ubuntu1.4 |
| Ubuntu:16.04:LTS | quagga | 0 | 0.99.24.1-2ubuntu1.3 |
| openSUSE:Tumbleweed | quagga | 0 | 1.2.4-2.14 |
Related vulnerabilities
- CVE-2017-16227 The aspath_put function in bgpd/bgp_aspath.c in Quagga before 1.2.2 allows remote… Also affects quagga
- CVE-2016-1245 It was discovered that the zebra daemon in Quagga before 1.0.20161017 suffered from a… Also affects quagga
- CVE-2016-2342 The bgp_nlri_parse_vpnv4 function in bgp_mplsvpn.c in the VPNv4 NLRI parser in bgpd in… Also affects quagga
- CVE-2013-2236 Stack-based buffer overflow in the new_msg_lsa_change_notify function in the OSPFD API… Also affects quagga
- CVE-2010-1674 The extended-community parser in bgpd in Quagga before 0.99.18 allows remote attackers to… Also affects quagga
- CVE-2018-5380 The Quagga BGP daemon (bgpd) prior to version 1.2.3 can overrun internal BGP… Also affects quagga
- CVE-2018-5378 The Quagga BGP daemon (bgpd) prior to version 1.2.3 does not properly bounds check the… Also affects quagga
- CVE-2018-5379 The Quagga BGP daemon (bgpd) prior to version 1.2.3 can double-free memory when… Also affects quagga