Cloudanix VulnDB

CVE-2017-15708

Critical · 9.8

CVSS

9.8

EPSS

17.9%

Published

Dec 11, 2017

CISA due date

—

The record

In Apache Synapse, by default no authentication is required for Java Remote Method Invocation (RMI). So Apache Synapse 3.0.1 or all previous releases (3.0.0, 2.1.0, 2.0.0, 1.2, 1.1.2, 1.1.1) allows remote code execution attacks that can be performed by injecting specially crafted serialized objects. And the presence of Apache Commons Collections 3.2.1 (commons-collections-3.2.1.jar) or previous versions in Synapse distribution makes this exploitable. To mitigate the issue, we need to limit RMI access to trusted users only. Further upgrading to 3.0.1 version will eliminate the risk of having said Commons Collection version. In Synapse 3.0.1, Commons Collection has been updated to 3.2.2 version.

Affected packages

Ecosystem Package Introduced Fixed
Maven org.apache.synapse:synapse-core 0 3.0.1
maven org.apache.synapse/synapse 1.0 No fix
maven org.apache.synapse/synapse 1.2 No fix
maven org.apache.synapse/synapse 2.0.0 No fix
maven org.apache.synapse/synapse 3.0.0 No fix

Related vulnerabilities