Cloudanix VulnDB

CVE-2017-12618

Medium · 4.7

CVSS

4.7

EPSS

0.6%

Published

Oct 24, 2017

CISA due date

—

Cloudanix analysis

Schedule a fix SSVC: Track

A problem in a supporting library can let someone who already has access to certain files on the same computer crash programs that use those files, briefly stopping services from working.

Exploitation
Local Privilege
Attacker needs
Low Privilege
Complexity
High
Impact
Denial Of Service
Component
Library
Class
Memory Corruption
Remediation
Upgrade
Effort
Medium
Patch risk
Low

What it actually does

Failure to validate SDBM database file integrity in apr_sdbm*() functions allows out-of-bounds read access when a malformed file is processed, resulting in process crash and denial of service.

Why it matters to the business

Local denial-of-service condition that can disrupt availability of affected services; low exploitation likelihood and no known ransomware or threat-actor usage reduce urgency, though widespread library dependency means many downstream packages remain exposed until patched.

How an attack unfolds

A local attacker with write access to an SDBM file used by APR-util crafts a malformed database file; when a vulnerable process loads the file via apr_sdbm functions the missing integrity checks trigger an out-of-bounds read that crashes the process.

How to fix it

Upgrade affected packages to the listed fixed versions: minio (Chainguard) 0.20231220.010002-r3, minio (Wolfi) 0.20231220.010002-r3, minio-bitnami-2024-compat (Chainguard) 0.20231220.010002-r3, minio-bitnami-2024-compat (Wolfi) 0.20231220.010002-r3; rebuild or redeploy containers with the updated packages and verify APR-util dependency versions are newer than 1.6.0.

How to confirm the fix worked

Confirm package versions match or exceed the fixed releases, run integration tests that exercise SDBM-backed functionality, and monitor for absence of crashes under load with known-good database files.

Typical attack path

  1. Obtain local write access to a target SDBM database file
  2. Modify or replace the file with crafted content that bypasses integrity checks
  3. Trigger execution of code paths that invoke apr_sdbm_open or related functions
  4. Cause out-of-bounds read leading to process termination and denial of service

How to detect it

Search process crash logs and core dumps for signals originating from APR-util SDBM functions; correlate with file modification timestamps on SDBM database files and unusual write activity by non-service accounts.

What your security team should do

  • Prioritize upgrade of all listed MinIO packages to the specified fixed versions within standard change windows
  • Inventory other services that link against APR-util and schedule upgrades
  • Add version pinning and SBOM checks to CI pipelines to prevent reintroduction of vulnerable APR-util
  • Review local file permissions on any SDBM files to reduce write-access surface

The record

Apache Portable Runtime Utility (APR-util) 1.6.0 and prior fail to validate the integrity of SDBM database files used by apr_sdbm*() functions, resulting in a possible out of bound read access. A local user with write access to the database can make a program or process using these functions crash, and cause a denial of service.

Affected packages

Ecosystem Package Introduced Fixed
Debian:10 apr-util 0 1.6.1-1
Debian:11 apr-util 0 1.6.1-1
Debian:12 apr-util 0 1.6.1-1
Debian:13 apr-util 0 1.6.1-1
Debian:7 apr-util 0 1.4.1-3+deb7u1
Mageia:5 apr-util 0 1.5.4-5.mga5
Mageia:6 apr-util 0 1.5.4-8.mga6
SUSE:Linux Enterprise Server 11 SP4 libapr-util1 0 1.3.4-12.22.23.3.2
SUSE:Linux Enterprise Server 12 SP2 libapr-util1 0 1.5.3-2.3.1
SUSE:Linux Enterprise Server 12 SP3 libapr-util1 0 1.5.3-2.3.1
SUSE:Linux Enterprise Server for Raspberry Pi 12 SP2 libapr-util1 0 1.5.3-2.3.1
SUSE:Linux Enterprise Server for SAP Applications 11 SP4 libapr-util1 0 1.3.4-12.22.23.3.2
SUSE:Linux Enterprise Server for SAP Applications 12 SP2 libapr-util1 0 1.5.3-2.3.1
SUSE:Linux Enterprise Server for SAP Applications 12 SP3 libapr-util1 0 1.5.3-2.3.1
SUSE:Linux Enterprise Software Development Kit 11 SP4 libapr-util1 0 1.3.4-12.22.23.3.2
SUSE:Linux Enterprise Software Development Kit 12 SP2 libapr-util1 0 1.5.3-2.3.1
SUSE:Linux Enterprise Software Development Kit 12 SP3 libapr-util1 0 1.5.3-2.3.1
SUSE:Studio Onsite 1.3 libapr-util1 0 1.3.4-12.22.23.3.2
Ubuntu:18.04:LTS apr-util 0 1.6.1-2
Ubuntu:Pro:14.04:LTS apr-util 0 1.5.3-1ubuntu0.1~esm1
Ubuntu:Pro:16.04:LTS apr-util 0 1.5.4-1ubuntu0.1~esm1
openSUSE:Tumbleweed apr-util 0 1.6.1-7.8

Related vulnerabilities