Cloudanix VulnDB

CVE-2017-1000024

High · 7.5

CVSS

7.5

EPSS

1.2%

Published

Jul 17, 2017

CISA due date

—

Cloudanix analysis

Schedule a fix SSVC: Track

A flaw in older versions of certain software can send passwords and login tokens over the internet without encryption, allowing them to be seen by others.

Exploitation
Remote Unauthenticated
Attacker needs
None
Complexity
Low
Impact
Data Exposure
Component
Application
Class
Information Disclosure
Remediation
Upgrade
Effort
Medium
Patch risk
Low

What it actually does

The vulnerability enables disclosure of sensitive credentials such as passwords and OAuth tokens in plaintext during transmission by web publishing plugins.

Why it matters to the business

Exposure of user credentials can lead to account compromises and unauthorized access to integrated services, increasing risk for organizations using affected packages across container ecosystems.

How an attack unfolds

An attacker intercepts network communications when the affected software uses web publishing features, capturing transmitted plaintext passwords and tokens without needing authentication.

How to fix it

Upgrade affected packages to the fixed versions such as kubernetes-1.29 (Chainguard): fixed in 1.29.4-r1 and equivalents for other listed packages.

How to confirm the fix worked

Verify package versions are at or above the fixed releases and test that publishing plugins no longer transmit credentials in plaintext.

Typical attack path

  1. Identify systems using vulnerable web publishing functionality
  2. Position to intercept network traffic (e.g., MITM)
  3. Capture and extract plaintext credentials from transmissions

How to detect it

Inspect network logs for unencrypted transmissions of credentials from web publishing activities in affected software versions.

What your security team should do

  • Prioritize updating all affected Kubernetes packages to version 1.29.4-r1 or later
  • Monitor for any credential exposure incidents
  • Review usage of web publishing plugins

The record

Shotwell version 0.24.4 or earlier and 0.25.3 or earlier is vulnerable to an information disclosure in the web publishing plugins resulting in potential password and oauth token plaintext transmission

Affected packages

Ecosystem Package Introduced Fixed
Debian:10 shotwell 0 0.25.4+really0.24.5-0.1
Debian:11 shotwell 0 0.25.4+really0.24.5-0.1
Debian:12 shotwell 0 0.25.4+really0.24.5-0.1
Debian:13 shotwell 0 0.25.4+really0.24.5-0.1
Mageia:5 shotwell 0 0.22.1-0.20160310.1.1.mga5
SUSE:Linux Enterprise Desktop 12 SP2 shotwell 0 0.22.0+git.20160103-15.6.1
SUSE:Linux Enterprise Desktop 12 SP3 shotwell 0 0.22.0+git.20160103-15.6.1
SUSE:Linux Enterprise Workstation Extension 12 SP2 shotwell 0 0.22.0+git.20160103-15.6.1
SUSE:Linux Enterprise Workstation Extension 12 SP3 shotwell 0 0.22.0+git.20160103-15.6.1
Ubuntu:14.04:LTS shotwell 0 0.18.0-0ubuntu4.5
Ubuntu:16.04:LTS shotwell 0 0.22.0+git20160108.r1.f2fb1f7-0ubuntu1.1

Related vulnerabilities