CVE-2016-1704
High · 8.8CVSS
8.8
EPSS
1.1%
Published
Jul 3, 2016
CISA due date
—
Cloudanix analysis
An old flaw in Chrome could let attackers crash the browser or worse when someone visits a bad webpage, so everyone needs to update their browser right away.
- Exploitation
- Requires User Interaction
- Attacker needs
- User Interaction
- Complexity
- Low
- Impact
- Other
- Component
- Application
- Class
- Other
- Remediation
- Upgrade
- Effort
- Medium
- Patch risk
- Low
What it actually does
Unspecified vulnerabilities in the browser engine allow remote attackers to trigger denial of service conditions or achieve other unspecified impacts, including potential memory corruption leading to arbitrary code execution, via specially crafted web content.
Why it matters to the business
Users on affected systems face risks of browser crashes, data exposure, or full system compromise when visiting malicious sites, increasing operational downtime and potential regulatory exposure across large user bases.
How an attack unfolds
An attacker hosts or compromises a website containing malicious content that exploits one or more of the unspecified flaws; when a victim visits the page with a vulnerable browser version, the flaw is triggered, resulting in denial of service or further impact.
How to fix it
Upgrade Google Chrome to version 51.0.2704.103 or later on all affected platforms; apply equivalent updates from distribution vendors for packaged versions on Ubuntu, RHEL, SUSE, and openSUSE.
How to confirm the fix worked
Verify installed Chrome version is 51.0.2704.103 or newer via chrome://version or package manager queries; re-test affected web content in updated browsers.
Typical attack path
- Attacker prepares malicious web content targeting the unspecified vulnerabilities
- Victim is directed to the attacker-controlled page via phishing or compromised site
- Vulnerable browser processes the content and triggers the flaw
- Impact manifests as crash, memory corruption, or other effects
How to detect it
Review web proxy and browser crash logs for unexpected terminations around the time of visits to suspicious domains; examine endpoint process trees for anomalous child processes spawned from chrome.exe or equivalent.
What your security team should do
- Prioritize immediate update of all Chrome instances to 51.0.2704.103 or later
- Block or monitor access to known malicious domains until patches are deployed
- Review endpoint detection for signs of browser exploitation in the interim
The record
Multiple unspecified vulnerabilities in Google Chrome before 51.0.2704.103 allow attackers to cause a denial of service or possibly have other impact via unknown vectors.
Affected packages
| Ecosystem | Package | Introduced | Fixed |
|---|---|---|---|
| Debian:8 | chromium-browser | 0 | 52.0.2743.82-1~deb8u1 |
| Mageia:5 | chromium-browser-stable | 0 | 51.0.2704.103-1.mga5 |
| Red Hat:rhel_extras:6 | chromium-browser | 0 | 0:51.0.2704.103-1.el6 |
| Red Hat:rhel_extras:6 | chromium-browser-debuginfo | 0 | 0:51.0.2704.103-1.el6 |
| SUSE:Package Hub 12 | chromium | 0 | 51.0.2704.103-85.3 |
| SUSE:Package Hub 12 | imlib2 | 0 | 1.4.5-5.1 |
| SUSE:Package Hub 12 | mosh | 0 | 1.2.5-8.1 |
| SUSE:Package Hub 12 | ninja | 0 | 1.5.3-4.1 |
| SUSE:Package Hub 12 | perl-Switch | 0 | 2.17-4.1 |
| SUSE:Package Hub 12 | protobuf | 0 | 2.5.0-2.1 |
| Ubuntu:14.04:LTS | chromium-browser | 0 | 52.0.2743.116-0ubuntu0.14.04.1.1134 |
| Ubuntu:14.04:LTS | oxide-qt | 0 | 1.15.8-0ubuntu0.14.04.1 |
| Ubuntu:16.04:LTS | chromium-browser | 0 | 52.0.2743.116-0ubuntu0.16.04.1.1250 |
| Ubuntu:16.04:LTS | oxide-qt | 0 | 1.15.8-0ubuntu0.16.04.1 |
| openSUSE:Tumbleweed | chromium | 0 | 55.0.2883.75-3.1 |
| openSUSE:Tumbleweed | chromium | 0 | 113.0.5672.92-1.1 |
Related vulnerabilities
- CVE-2016-9651 A missing check for whether a property of a JS object is private in V8 in Google Chrome… Also affects chromium-browser
- CVE-2017-5029 The xsltAddTextString function in transform.c in libxslt 1.1.29, as used in Blink in… Also affects chromium-browser
- CVE-2017-5040 V8 in Google Chrome prior to 57.0.2987.98 for Mac, Windows, and Linux and 57.0.2987.108… Also affects chromium-browser
- CVE-2017-5030 Incorrect handling of complex species in V8 in Google Chrome prior to 57.0.2987.98 for… Also affects chromium-browser
- CVE-2017-5006 Blink in Google Chrome prior to 56.0.2924.76 for Linux, Windows and Mac, and 56.0.2924.87… Also affects chromium-browser
- CVE-2016-5198 V8 in Google Chrome prior to 54.0.2840.90 for Linux, and 54.0.2840.85 for Android, and… Also affects chromium-browser
- CVE-2016-5204 Leaking of an SVG shadow tree leading to corruption of the DOM tree in Blink in Google… Also affects chromium-browser
- CVE-2016-5170 WebKit/Source/bindings/modules/v8/V8BindingForModules.cpp in Blink, as used in Google… Also affects chromium-browser