CVE-2015-6806
NoneCVSS
—
EPSS
4.1%
Published
Sep 28, 2015
CISA due date
—
Cloudanix analysis
A flaw in an old terminal program lets attackers send special text that makes the program crash from too much internal recursion.
- Exploitation
- Remote Unauthenticated
- Attacker needs
- None
- Complexity
- Low
- Impact
- Denial Of Service
- Component
- Application
- Class
- Memory Corruption
- Remediation
- Upgrade
- Effort
- Medium
- Patch risk
- Low
What it actually does
Unbounded recursion in MScrollV when processing an escape sequence with a large repeat count leads to stack exhaustion and process crash.
Why it matters to the business
Attackers can remotely crash terminal multiplexers, interrupting user sessions and requiring manual restarts with potential loss of unsaved work.
How an attack unfolds
An attacker sends a crafted ANSI escape sequence containing a large repeat count directly to a vulnerable screen instance; the MScrollV handler recurses without limit until the stack is exhausted.
How to fix it
Upgrade GNU screen to a version newer than 4.3.1 that contains the recursion limit fix; if no newer package is available, replace the utility or restrict exposure of terminal sessions to untrusted input.
How to confirm the fix worked
Confirm the installed screen binary version is newer than 4.3.1 and test that the MScrollV recursion path rejects oversized repeat counts without crashing.
Typical attack path
- Identify a target running an exposed or locally reachable GNU screen session
- Craft an escape sequence with an oversized repeat count value
- Deliver the sequence via terminal input, paste, or network protocol that reaches the ansi parser
- Trigger stack consumption resulting in immediate denial of service
How to detect it
Review terminal session logs and process crash reports for sudden stack overflows or segmentation faults immediately after receipt of ANSI escape sequences; correlate with user activity that includes pasted or received terminal control data.
What your security team should do
- Immediately upgrade all GNU screen installations to a fixed release
- Disable or sandbox screen where untrusted input can reach the terminal emulator
- Monitor for any remaining instances older than 4.3.1 and prioritize replacement
The record
The MScrollV function in ansi.c in GNU screen 4.3.1 and earlier does not properly limit recursion, which allows remote attackers to cause a denial of service (stack consumption) via an escape sequence with a large repeat count value.
Affected packages
| Ecosystem | Package | Introduced | Fixed |
|---|---|---|---|
| Debian:11 | screen | 0 | 4.3.1-2 |
| Debian:12 | screen | 0 | 4.3.1-2 |
| Debian:13 | screen | 0 | 4.3.1-2 |
| Debian:6.0 | screen | 0 | 4.0.3-14+deb6u1 |
| Debian:7 | screen | 0 | 4.1.0~20120320gitdb59704-7+deb7u1 |
| Debian:8 | screen | 0 | 4.2.1-3+deb8u1 |
| Mageia:4 | screen | 0 | 4.0.3-13.1.mga4 |
| Mageia:5 | screen | 0 | 4.2.1-3.1.mga5 |
| SUSE:Linux Enterprise Desktop 12 SP3 | screen | 0 | 4.0.4-23.3.3 |
| SUSE:Linux Enterprise Desktop 12 SP4 | screen | 0 | 4.0.4-23.3.3 |
| SUSE:Linux Enterprise Server 12 SP3 | screen | 0 | 4.0.4-23.3.3 |
| SUSE:Linux Enterprise Server 12 SP4 | screen | 0 | 4.0.4-23.3.3 |
| SUSE:Linux Enterprise Server for SAP Applications 12 SP3 | screen | 0 | 4.0.4-23.3.3 |
| SUSE:Linux Enterprise Server for SAP Applications 12 SP4 | screen | 0 | 4.0.4-23.3.3 |
| Ubuntu:14.04:LTS | screen | 0 | 4.1.0~20120320gitdb59704-9ubuntu0.1~esm1 |
| Ubuntu:16.04:LTS | screen | 0 | 4.3.1-2 |
| Ubuntu:Pro:14.04:LTS | screen | 0 | 4.1.0~20120320gitdb59704-9ubuntu0.1~esm1 |
Related vulnerabilities
- CVE-2026-112108 A vulnerability was determined in ztxz16 fastllm up to 0.1.8.2. CWE-119
- CVE-2026-112073 A vulnerability was identified in Tencent ncnn up to 44b02dabdcf97499281a4692ebd65bad73dc… CWE-119
- CVE-2026-90831 A vulnerability was detected in GNU Binutils 2.47. CWE-119
- CVE-2026-90804 A vulnerability was detected in GNU Binutils 2.47. CWE-119
- CVE-2026-90803 A security vulnerability has been detected in GNU Binutils 2.47. CWE-119
- CVE-2026-90801 A security flaw has been discovered in GNU Binutils 2.47. CWE-119
- CVE-2026-87933 A vulnerability was found in DaveGamble cJSON up to 1.7.19. CWE-119
- CVE-2026-87931 A vulnerability has been found in Behavioral Technology Group Pavlok Behavioral… CWE-119