CVE-2015-6031
NoneCVSS
—
EPSS
4.8%
Published
Nov 2, 2015
CISA due date
—
Cloudanix analysis
A flaw in a common network-discovery tool can let a nearby device crash the program or take control of the computer, so updating the tool removes the weakness.
- Exploitation
- Remote Unauthenticated
- Attacker needs
- None
- Complexity
- Moderate
- Impact
- Remote Code Execution
- Component
- Library
- Class
- Memory Corruption
- Remediation
- Upgrade
- Effort
- Medium
- Patch risk
- Low
What it actually does
Buffer overflow in the IGDstartelt XML parsing function allows a remote UPnP server to write beyond allocated memory, resulting in application crash or potential arbitrary code execution.
Why it matters to the business
Systems relying on the MiniUPnP client for network discovery may experience sudden crashes, loss of UPnP functionality, or full host compromise when interacting with malicious or compromised UPnP devices on the network.
How an attack unfolds
An attacker hosts or compromises a UPnP server that responds to discovery requests with an XML document containing an oversized element name, triggering the overflow during parsing in the vulnerable client library.
How to fix it
Upgrade the MiniUPnP client library to version 1.9.20150917 or later; rebuild and redeploy any applications statically or dynamically linking the vulnerable library; replace or isolate affected devices that bundle unpatchable copies.
How to confirm the fix worked
Inventory all binaries and packages using the miniupnpc library, verify reported version is 1.9.20150917 or newer, and test that UPnP discovery completes without crashes against both legitimate and large-element-name test servers.
Typical attack path
- Attacker places a malicious UPnP server on the same network or reachable via multicast
- Vulnerable MiniUPnP client sends a discovery request or receives an unsolicited advertisement
- Server returns a crafted XML response with an oversized element name
- Client parses the response in IGDstartelt and overflows the buffer
- Resulting crash or code execution occurs on the client host
How to detect it
Search process crash logs and core dumps for miniupnpc or IGDstartelt symbols, inspect network captures for UPnP responses containing unusually long XML element names, and review application logs for sudden termination during UPnP discovery.
- IGDstartelt
- miniupnpc
- oversized XML element name in SSDP/UPnP responses
What your security team should do
- Immediately identify and patch all instances of miniupnpc older than 1.9.20150917 across Linux distributions and embedded products
- Disable UPnP client functionality where not required
- Monitor network for unexpected UPnP traffic and application crashes in processes using the library
- Apply vendor updates for Debian, Ubuntu, openSUSE, and other affected distributions as they become available
The record
Buffer overflow in the IGDstartelt function in igd_desc_parse.c in the MiniUPnP client (aka MiniUPnPc) before 1.9.20150917 allows remote UPNP servers to cause a denial of service (application crash) and possibly execute arbitrary code via an "oversized" XML element name.
Affected packages
| Ecosystem | Package | Introduced | Fixed |
|---|---|---|---|
| Debian:11 | miniupnpc | 0 | 1.9.20140610-2.1 |
| Debian:12 | miniupnpc | 0 | 1.9.20140610-2.1 |
| Debian:13 | miniupnpc | 0 | 1.9.20140610-2.1 |
| Debian:7 | miniupnpc | 0 | 1.5-2+deb7u1 |
| Debian:8 | miniupnpc | 0 | 1.9.20140610-2+deb8u1 |
| Mageia:5 | miniupnpc | 0 | 1.9.20141128-1.1.mga5 |
| Ubuntu:14.04:LTS | miniupnpc | 0 | 1.6-3ubuntu2.14.04.2 |
Related vulnerabilities
- CVE-2017-8798 Integer signedness error in MiniUPnP MiniUPnPc v1.4.20101221 through v2.0 allows remote… Also affects miniupnpc
- CVE-2014-3985 The getHTTPResponse function in miniwget.c in MiniUPnP 1.9 allows remote attackers to… Also affects miniupnpc
- CVE-2026-112108 A vulnerability was determined in ztxz16 fastllm up to 0.1.8.2. CWE-119
- CVE-2026-112073 A vulnerability was identified in Tencent ncnn up to 44b02dabdcf97499281a4692ebd65bad73dc… CWE-119
- CVE-2026-90831 A vulnerability was detected in GNU Binutils 2.47. CWE-119
- CVE-2026-90804 A vulnerability was detected in GNU Binutils 2.47. CWE-119
- CVE-2026-90803 A security vulnerability has been detected in GNU Binutils 2.47. CWE-119
- CVE-2026-90801 A security flaw has been discovered in GNU Binutils 2.47. CWE-119