CVE-2015-3622
NoneCVSS
—
EPSS
32.9%
Published
May 12, 2015
CISA due date
—
Cloudanix analysis
A bug in a common library for reading digital certificates can let attackers crash programs simply by sending a specially formatted certificate.
- Exploitation
- Remote Unauthenticated
- Attacker needs
- None
- Complexity
- Moderate
- Impact
- Denial Of Service
- Component
- Library
- Class
- Memory Corruption
- Remediation
- Upgrade
- Effort
- Low
- Patch risk
- Low
What it actually does
Out-of-bounds heap read in _asn1_extract_der_octet during DER octet string extraction from crafted ASN.1 certificate data, resulting in denial of service.
Why it matters to the business
Services and applications that parse untrusted certificates using the library may crash or become unavailable, affecting operations that depend on secure certificate handling.
How an attack unfolds
An attacker supplies a maliciously crafted certificate to any application linked against the vulnerable library; the _asn1_extract_der_octet function performs an out-of-bounds heap read when processing the certificate's ASN.1 structure, triggering a crash.
How to fix it
Upgrade GNU Libtasn1 to version 4.5 or newer on all affected systems and rebuild dependent packages; apply vendor patches for opensuse and fedora distributions.
How to confirm the fix worked
Confirm installed libtasn1 version is 4.5 or later via package manager or library metadata; test certificate parsing with known malformed inputs to verify absence of crashes.
Typical attack path
- Locate a network service or application that uses libtasn1 to parse certificates
- Generate a certificate containing malformed DER encoding targeting the octet extraction path
- Deliver the certificate via TLS handshake, file upload, or other certificate ingestion mechanism
- Trigger the vulnerable decoding path leading to heap read outside allocated bounds and process termination
How to detect it
Review application and system logs for abrupt crashes or segmentation faults during certificate validation or ASN.1 decoding operations; correlate with inbound certificate-bearing network traffic.
What your security team should do
- Immediately update libtasn1 across all environments given the public exploit availability
- Inventory all software depending on libtasn1 and schedule rebuilds after library upgrade
- Enable application crash reporting and monitor logs for ASN.1 parsing failures
The record
The _asn1_extract_der_octet function in lib/decoding.c in GNU Libtasn1 before 4.5 allows remote attackers to cause a denial of service (out-of-bounds heap read) via a crafted certificate.
Affected packages
| Ecosystem | Package | Introduced | Fixed |
|---|---|---|---|
| Debian:11 | libtasn1-6 | 0 | 4.4-3 |
| Debian:12 | libtasn1-6 | 0 | 4.4-3 |
| Debian:13 | libtasn1-6 | 0 | 4.4-3 |
| Debian:8 | libtasn1-6 | 0 | 4.2-3+deb8u1 |
| Mageia:4 | libtasn1 | 0 | 3.6-1.2.mga4 |
| Red Hat:enterprise_linux:7::client | libtasn1 | 0 | 0:4.10-1.el7 |
| Red Hat:enterprise_linux:7::client | libtasn1-debuginfo | 0 | 0:4.10-1.el7 |
| Red Hat:enterprise_linux:7::client | libtasn1-devel | 0 | 0:4.10-1.el7 |
| Red Hat:enterprise_linux:7::client | libtasn1-tools | 0 | 0:4.10-1.el7 |
| Red Hat:enterprise_linux:7::computenode | libtasn1 | 0 | 0:4.10-1.el7 |
| Red Hat:enterprise_linux:7::computenode | libtasn1-debuginfo | 0 | 0:4.10-1.el7 |
| Red Hat:enterprise_linux:7::computenode | libtasn1-devel | 0 | 0:4.10-1.el7 |
| Red Hat:enterprise_linux:7::computenode | libtasn1-tools | 0 | 0:4.10-1.el7 |
| Red Hat:enterprise_linux:7::server | libtasn1 | 0 | 0:4.10-1.el7 |
| Red Hat:enterprise_linux:7::server | libtasn1-debuginfo | 0 | 0:4.10-1.el7 |
| Red Hat:enterprise_linux:7::server | libtasn1-devel | 0 | 0:4.10-1.el7 |
| Red Hat:enterprise_linux:7::server | libtasn1-tools | 0 | 0:4.10-1.el7 |
| Red Hat:enterprise_linux:7::workstation | libtasn1 | 0 | 0:4.10-1.el7 |
| Red Hat:enterprise_linux:7::workstation | libtasn1-debuginfo | 0 | 0:4.10-1.el7 |
| Red Hat:enterprise_linux:7::workstation | libtasn1-devel | 0 | 0:4.10-1.el7 |
| Red Hat:enterprise_linux:7::workstation | libtasn1-tools | 0 | 0:4.10-1.el7 |
| SUSE:Linux Enterprise Desktop 12 | gnutls | 0 | 3.2.15-11.1 |
| SUSE:Linux Enterprise Desktop 12 | libtasn1 | 0 | 3.7-11.1 |
| SUSE:Linux Enterprise Desktop 12 SP1 | libtasn1 | 0 | 3.7-11.1 |
| SUSE:Linux Enterprise Server 11 SP4 | libtasn1 | 0 | 1.5-1.34.1 |
| SUSE:Linux Enterprise Server 12 | gnutls | 0 | 3.2.15-11.1 |
| SUSE:Linux Enterprise Server 12 | libtasn1 | 0 | 3.7-11.1 |
| SUSE:Linux Enterprise Server 12 SP1 | libtasn1 | 0 | 3.7-11.1 |
| SUSE:Linux Enterprise Server for SAP Applications 11 SP4 | libtasn1 | 0 | 1.5-1.34.1 |
| SUSE:Linux Enterprise Server for SAP Applications 12 | gnutls | 0 | 3.2.15-11.1 |
| SUSE:Linux Enterprise Server for SAP Applications 12 | libtasn1 | 0 | 3.7-11.1 |
| SUSE:Linux Enterprise Server for SAP Applications 12 SP1 | libtasn1 | 0 | 3.7-11.1 |
| SUSE:Linux Enterprise Software Development Kit 11 SP4 | libtasn1 | 0 | 1.5-1.34.1 |
| SUSE:Linux Enterprise Software Development Kit 12 | gnutls | 0 | 3.2.15-11.1 |
| SUSE:Linux Enterprise Software Development Kit 12 | libtasn1 | 0 | 3.7-11.1 |
| SUSE:Linux Enterprise Software Development Kit 12 SP1 | libtasn1 | 0 | 3.7-11.1 |
| Ubuntu:14.04:LTS | libtasn1-6 | 0 | 3.4-3ubuntu0.3 |
| openSUSE:Tumbleweed | libtasn1 | 0 | 4.9-1.3 |
Related vulnerabilities
- CVE-2018-1000654 GNU Libtasn1-4.13 libtasn1-4.13 version libtasn1-4.13, libtasn1-4.12 contains a DoS… Also affects libtasn1-6
- CVE-2017-10790 The _asn1_check_identifier function in GNU Libtasn1 through 4.12 causes a NULL pointer… Also affects libtasn1-6
- CVE-2017-6891 Two errors in the "asn1_find_node()" function (lib/parser_aux.c) within GnuTLS libtasn1… Also affects libtasn1-6
- CVE-2016-4008 The _asn1_extract_der_octet function in lib/decoding.c in GNU Libtasn1 before 4.8, when… Also affects libtasn1-6
- CVE-2015-2806 Stack-based buffer overflow in asn1_der_decoding in libtasn1 before 4.4 allows remote… Also affects libtasn1-6
- CVE-2014-3467 Multiple unspecified vulnerabilities in the DER decoder in GNU Libtasn1 before 3.6, as… Also affects libtasn1-6
- CVE-2015-6251 Double free vulnerability in GnuTLS before 3.3.17 and 3.4.x before 3.4.4 allows remote… Also affects gnutls
- CVE-2025-13151 Stack-based buffer overflow in libtasn1 version: v4.20.0. Also affects libtasn1