Cloudanix VulnDB

CVE-2015-3200

High · 7.5

CVSS

7.5

EPSS

9.9%

Published

Jun 9, 2015

CISA due date

—

Cloudanix analysis

Schedule a fix SSVC: Track

A web server used in certain packaged deployments lets attackers secretly add fake lines to its login records by sending specially formatted login attempts.

Exploit Available
Exploitation
Remote Unauthenticated
Attacker needs
None
Complexity
Low
Impact
Data Tampering
Component
Network Service
Class
Improper Input Validation
Remediation
Upgrade
Effort
Medium
Patch risk
Low

What it actually does

The flaw permits remote attackers to inject arbitrary entries into authentication logs by supplying a malformed Basic HTTP Authorization header that lacks a colon and contains embedded null bytes or newline characters, bypassing normal sanitization in mod_auth.

Why it matters to the business

Attackers can poison server logs, potentially concealing malicious activity, misleading incident responders, or enabling follow-on log-based attacks; the affected Bitnami-packaged deployment has been exposed for over a decade with publicly available exploit code.

How an attack unfolds

An attacker crafts an HTTP request containing a Basic Authorization header whose Base64-decoded value omits the required colon separator and embeds newline or null characters; when processed by the vulnerable mod_auth module the server writes the injected content directly into its log files, allowing forged log lines that can mask subsequent activity.

How to fix it

Upgrade the affected Bitnami vault package to version 1.15.12 or later; if an immediate upgrade is not feasible, restrict access to the authentication endpoint or deploy a reverse proxy that normalizes Authorization headers before they reach the server.

How to confirm the fix worked

Confirm the deployed package version meets or exceeds 1.15.12; test by replaying a request with a Basic Authorization value lacking a colon and containing a newline, verifying that the log entry is rejected or properly escaped rather than injected verbatim.

Typical attack path

  1. Identify an exposed service using the vulnerable authentication module
  2. Send an HTTP request with a specially crafted Basic Authorization header containing no colon and embedded control characters
  3. Observe successful injection of arbitrary text into authentication logs
  4. Leverage the poisoned logs to evade detection or support chained attacks

How to detect it

Search web server access and error logs for Basic Authorization header values that lack a colon after decoding or contain literal newline or null characters; correlate with unusual spikes in authentication attempts from single sources.

What your security team should do

  • Prioritize upgrade to the fixed version 1.15.12 within the next maintenance window
  • Add WAF or proxy rules that drop or sanitize Basic Authorization headers containing newlines or null bytes
  • Review historical authentication logs for any entries with unusual null or newline artifacts
  • Monitor EPSS and exploit availability trends for any increase in observed scanning

The record

mod_auth in lighttpd before 1.4.36 allows remote attackers to inject arbitrary log entries via a basic HTTP authentication string without a colon character, as demonstrated by a string containing a NULL and new line character.

Affected packages

Ecosystem Package Introduced Fixed
Debian:10 lighttpd 0 1.4.37-1
Debian:11 lighttpd 0 1.4.37-1
Debian:12 lighttpd 0 1.4.37-1
Debian:13 lighttpd 0 1.4.37-1
Mageia:4 lighttpd 0 1.4.37-1.mga4
Mageia:5 lighttpd 0 1.4.37-1.mga5
SUSE:Linux Enterprise High Availability Extension 11 SP4 lighttpd 0 1.4.20-2.58.1
SUSE:Linux Enterprise High Availability Extension 12 SP1 lighttpd 0 1.4.35-3.1
SUSE:Linux Enterprise High Availability Extension 12 SP2 lighttpd 0 1.4.35-3.1
SUSE:Linux Enterprise Server for SAP Applications 11 SP4 lighttpd 0 1.4.20-2.58.1
SUSE:Linux Enterprise Server for SAP Applications 12 lighttpd 0 1.4.35-3.1
SUSE:Linux Enterprise Software Development Kit 11 SP4 lighttpd 0 1.4.20-2.58.1
Ubuntu:18.04:LTS lighttpd 0 1.4.45-1ubuntu3
Ubuntu:Pro:14.04:LTS lighttpd 0 1.4.33-1+nmu2ubuntu2.1+esm1
Ubuntu:Pro:16.04:LTS lighttpd 0 1.4.35-4ubuntu2.1+esm1
Ubuntu:Pro:18.04:LTS lighttpd 0 1.4.45-1ubuntu3.18.04.1+esm1

Related vulnerabilities