CVE-2015-1330
NoneCVSS
—
EPSS
1.4%
Published
Jul 1, 2015
CISA due date
—
Cloudanix analysis
Outdated update software on some Linux computers can let someone on the same network secretly replace normal updates with harmful ones, giving them control of the machine.
- Exploitation
- Remote Unauthenticated
- Attacker needs
- None
- Complexity
- Moderate
- Impact
- Remote Code Execution
- Component
- Application
- Class
- Authentication Bypass
- Remediation
- Upgrade
- Effort
- Medium
- Patch risk
- Low
What it actually does
The flaw bypasses package signature and origin authentication in unattended-upgrades when force-confold or force-confnew dpkg options are present in DPkg::Options, allowing a network attacker to substitute and install arbitrary packages.
Why it matters to the business
Systems remain exposed to silent installation of malicious software during routine unattended updates, increasing risk of persistent compromise on legacy Ubuntu and Debian deployments that have not been upgraded since 2015.
How an attack unfolds
An attacker performs a man-in-the-middle position on the network path to the configured package repositories; when unattended-upgrades runs it fetches package metadata and debs under the force-conf options; the attacker substitutes a malicious package that passes the weakened checks and gets installed and executed with root privileges.
How to fix it
Upgrade unattended-upgrades to version 0.86.1 or later on all affected Ubuntu and Debian systems; remove force-confold and force-confnew from any DPkg::Options entries in apt configuration; test the updated configuration in a non-production environment before wide rollout.
How to confirm the fix worked
Verify the installed unattended-upgrades package version is at least 0.86.1; inspect /etc/apt/apt.conf.d/ for any remaining DPkg::Options containing force-confold or force-confnew; run unattended-upgrades in dry-run mode and confirm package signature verification occurs.
Typical attack path
- Establish man-in-the-middle network position between the host and package mirrors
- Wait for or trigger an unattended-upgrades execution cycle
- Intercept repository index and package downloads
- Substitute a crafted package that satisfies the force-confold/new handling
- Allow dpkg to install and configure the malicious package with elevated privileges
How to detect it
Review unattended-upgrades and apt history logs for package installations that occurred without expected signature verification messages; correlate with network flow data showing unexpected repository traffic; search for dpkg processes launched under non-standard options around update windows.
What your security team should do
- Immediately inventory all systems running unattended-upgrades older than 0.86.1 and schedule upgrades
- Audit apt configuration files across the environment for the presence of force-conf options and remove them where possible
- Enable verbose logging for unattended-upgrades and forward logs to a central SIEM for anomaly detection
- Consider replacing unattended-upgrades with a more modern, authenticated update mechanism on long-lived systems
The record
unattended-upgrades before 0.86.1 does not properly authenticate packages when the (1) force-confold or (2) force-confnew dpkg options are enabled in the DPkg::Options::* apt configuration, which allows remote man-in-the-middle attackers to upload and execute arbitrary packages via unspecified vectors.
Affected packages
| Ecosystem | Package | Introduced | Fixed |
|---|---|---|---|
| Debian:11 | unattended-upgrades | 0 | 0.86.1 |
| Debian:12 | unattended-upgrades | 0 | 0.86.1 |
| Debian:13 | unattended-upgrades | 0 | 0.86.1 |
| Debian:6.0 | unattended-upgrades | 0 | 0.62.2+squeeze1 |
| Debian:7 | unattended-upgrades | 0 | 0.79.5+wheezy2 |
| Debian:8 | unattended-upgrades | 0 | 0.83.3.2+deb8u1 |
| Ubuntu:14.04:LTS | unattended-upgrades | 0 | 0.82.1ubuntu2.3 |
Related vulnerabilities
- CVE-2026-114638 Traefik v3.7.0 before v3.7.14 contains an improper authentication vulnerability in the… CWE-287
- CVE-2026-114639 Traefik 2.11.0 before 2.11.58 and 3.0.0 before 3.7.14 contains an authentication bypass… CWE-287
- CVE-2026-112104 A flaw has been found in eremef bandcamp-player up to 1.8.33-beta. CWE-287
- CVE-2026-107228 The AsyncHttpClient (AHC) library allows Java applications to easily execute HTTP… CWE-287
- CVE-2026-86781 The SSL Zen — SSL Certificate Installer & HTTPS Redirects WordPress plugin before 4.7.40… CWE-287
- CVE-2026-14563 The advanced-customized-prompts WordPress plugin through 1.0.1 does not verify the… CWE-287
- CVE-2026-14559 The teddy-bear-customize-addon WordPress plugin through 1.0.5 does not verify a user's… CWE-287
- CVE-2026-88895 CyberPanel before 3.0.5 fails to enforce two-factor authentication on API endpoints… CWE-287