CVE-2014-9218
NoneCVSS
—
EPSS
11.5%
Published
Dec 8, 2014
CISA due date
—
Cloudanix analysis
Attackers can make the application unavailable by sending an extremely long password that overwhelms its processing resources.
- Exploitation
- Remote Unauthenticated
- Attacker needs
- None
- Complexity
- Low
- Impact
- Denial Of Service
- Component
- Application
- Class
- Denial of service
- Remediation
- Upgrade
- Effort
- Medium
- Patch risk
- Low
What it actually does
Remote unauthenticated attackers can trigger excessive resource consumption in the authentication handling code by submitting an extremely long password value, leading to denial of service.
Why it matters to the business
Application availability can be disrupted, causing downtime for administrative interfaces and any dependent services until the affected instance is restarted or the traffic is filtered.
How an attack unfolds
An attacker identifies a reachable phpMyAdmin login endpoint and repeatedly submits HTTP requests containing an abnormally long password string; the server allocates resources to process the input without sufficient limits, exhausting CPU or memory and rendering the service unresponsive. No authentication or special privileges are required.
How to fix it
Upgrade affected installations to the fixed versions provided by the vendor; for vault (Bitnami) deployments apply the update to version 1.8.0 or later. If immediate patching is not possible, restrict network access to the administrative interface or deploy request-length filtering at a web application firewall.
How to confirm the fix worked
Confirm the installed version matches or exceeds the fixed release, then attempt to reproduce the original long-password request in a controlled environment while monitoring resource usage to verify the denial-of-service condition no longer occurs.
Typical attack path
- Locate an exposed phpMyAdmin or affected application login page
- Craft an HTTP POST or GET request containing a password parameter exceeding normal length limits
- Send the request, optionally in volume, to trigger resource consumption
- Observe service degradation or crash on the target
How to detect it
Review web server and application logs for authentication requests containing unusually long password fields; correlate with spikes in CPU or memory usage on the hosting server. No persistent artifacts remain after the attack ends.
What your security team should do
- Prioritize patching to the stated fixed version within the next maintenance window given the public exploit availability
- Restrict direct internet exposure of administrative interfaces until patched
- Implement input-length validation or rate limiting on authentication endpoints as a compensating control
The record
libraries/common.inc.php in phpMyAdmin 4.0.x before 4.0.10.7, 4.1.x before 4.1.14.8, and 4.2.x before 4.2.13.1 allows remote attackers to cause a denial of service (resource consumption) via a long password.
Affected packages
| Ecosystem | Package | Introduced | Fixed |
|---|---|---|---|
| Debian:11 | phpmyadmin | 0 | 4:4.2.12-2 |
| Debian:12 | phpmyadmin | 0 | 4:4.2.12-2 |
| Debian:13 | phpmyadmin | 0 | 4:4.2.12-2 |
| Debian:6.0 | phpmyadmin | 0 | 4:3.3.7-9 |
| Debian:7 | phpmyadmin | 0 | 4:3.4.11.1-2+deb7u2 |
| Debian:8 | phpmyadmin | 0 | 4:4.2.12-2+deb8u1 |
| Mageia:4 | phpmyadmin | 0 | 4.1.14.8-1.mga4 |
| Ubuntu:Pro:14.04:LTS | phpmyadmin | 0 | 4:4.0.10-1ubuntu0.1+esm4 |
| Ubuntu:Pro:16.04:LTS | phpmyadmin | 0 | 4:4.5.4.1-2ubuntu2.1+esm6 |
| Ubuntu:Pro:18.04:LTS | phpmyadmin | 0 | 4:4.6.6-5ubuntu0.5+esm1 |
| Ubuntu:Pro:20.04:LTS | phpmyadmin | 0 | 4:4.9.5+dfsg1-2ubuntu0.1~esm1 |
| openSUSE:Tumbleweed | phpMyAdmin | 0 | 4.6.5.2-1.1 |
Related vulnerabilities
- CVE-2025-24530 An issue was discovered in phpMyAdmin 5.x before 5.2.2. Also affects phpmyadmin
- CVE-2025-24529 An issue was discovered in phpMyAdmin 5.x before 5.2.2. Also affects phpmyadmin
- CVE-2016-5734 phpMyAdmin 4.0.x before 4.0.10.16, 4.4.x before 4.4.15.7, and 4.6.x before 4.6.3 does not… Also affects phpmyadmin
- CVE-2015-6830 libraries/plugins/auth/AuthenticationCookie.class.php in phpMyAdmin 4.3.x before 4.3.13.2… Also affects phpmyadmin
- CVE-2011-4107 The simplexml_load_string function in the XML import plug-in (libraries/import/xml.php)… Also affects phpmyadmin
- CVE-2011-2505 libraries/auth/swekey/swekey.auth.lib.php in the Swekey authentication feature in… Also affects phpmyadmin
- CVE-2010-3055 The configuration setup script (aka scripts/setup.php) in phpMyAdmin 2.11.x before… Also affects phpmyadmin
- CVE-2009-1285 Static code injection vulnerability in the getConfigFile function in… Also affects phpmyadmin