Cloudanix VulnDB

CVE-2014-6272

None

CVSS

—

EPSS

2.1%

Published

Aug 24, 2015

CISA due date

—

Cloudanix analysis

Schedule a fix SSVC: Track

A problem in a widely used networking helper library can let remote attackers crash programs or potentially take them over by feeding them extremely large pieces of data.

Exploitation
Remote Unauthenticated
Attacker needs
None
Complexity
Low
Impact
Denial Of Service
Component
Library
Class
Buffer Overflow
Remediation
Upgrade
Effort
Medium
Patch risk
Low

What it actually does

Integer overflows in evbuffer_add, evbuffer_expand, and bufferevent_write allow heap-based buffer overflows or infinite loops when processing excessively large inputs.

Why it matters to the business

Applications using Libevent for network handling may crash or behave unexpectedly, leading to service outages in servers and tools that depend on the library.

How an attack unfolds

An attacker sends oversized network inputs to trigger the integer overflow in one of the three affected functions, resulting in memory corruption that can be leveraged for denial of service or further impact.

How to fix it

Upgrade Libevent to 1.4.15 or newer, 2.0.22 or newer, or 2.1.5-beta or newer; rebuild and redeploy any affected applications.

How to confirm the fix worked

Confirm the running Libevent version meets or exceeds the fixed releases and perform fuzz testing with large inputs to the evbuffer API.

Typical attack path

  1. Locate services or binaries linked against vulnerable Libevent versions
  2. Craft and transmit an input exceeding safe size limits to evbuffer_add, evbuffer_expand, or bufferevent_write
  3. Trigger heap overflow or loop to disrupt or compromise the process

How to detect it

Review process crash reports, memory dumps, and application logs for signs of buffer handling failures or unexpected termination after receiving large network payloads.

What your security team should do

  • Prioritize patching Libevent across all deployments given the network-reachable attack surface
  • Inventory software that statically or dynamically links the library
  • Monitor memory and CPU usage for anomalous spikes during input processing

The record

Multiple integer overflows in the evbuffer API in Libevent 1.4.x before 1.4.15, 2.0.x before 2.0.22, and 2.1.x before 2.1.5-beta allow context-dependent attackers to cause a denial of service or possibly have other unspecified impact via "insanely large inputs" to the (1) evbuffer_add, (2) evbuffer_expand, or (3) bufferevent_write function, which triggers a heap-based buffer overflow or an infinite loop. NOTE: this identifier has been SPLIT per ADT3 due to different affected versions. See CVE-2015-6525 for the functions that are only affected in 2.0 and later.

Affected packages

Ecosystem Package Introduced Fixed
Debian:11 libevent 0 2.0.21-stable-2
Debian:12 libevent 0 2.0.21-stable-2
Debian:13 libevent 0 2.0.21-stable-2
Debian:6.0 libevent 0 1.4.13-stable-1+deb6u1
Debian:7 libevent 0 2.0.19-stable-3+deb7u1
Mageia:4 libevent 0 2.0.21-5.1.mga4
Ubuntu:14.04:LTS libevent 0 2.0.21-stable-1ubuntu1.14.04.1
openSUSE:Tumbleweed dnscrypt-proxy 0 2.1.0-1.2

Related vulnerabilities