CVE-2014-5461
NoneCVSS
—
EPSS
12.0%
Published
Sep 4, 2014
CISA due date
—
Cloudanix analysis
A problem in an older version of the Lua programming language can make programs that use it stop working suddenly.
- Exploitation
- Remote Unauthenticated
- Attacker needs
- None
- Complexity
- Low
- Impact
- Denial Of Service
- Component
- Library
- Class
- Memory Corruption
- Remediation
- Upgrade
- Effort
- Medium
- Patch risk
- Low
What it actually does
Buffer overflow in Lua's vararg function handling in ldo.c allows a crash when a function with many fixed arguments receives few actual arguments.
Why it matters to the business
Applications and services embedding older Lua versions risk unexpected crashes and service outages; the vulnerability has been known since 2014 with low but persistent exploitation probability and affects common Linux distributions.
How an attack unfolds
An attacker supplies crafted input or script that invokes a Lua function defined with a large number of fixed parameters while passing only a small number of arguments, triggering the overflow in the vararg processing code and causing a denial-of-service crash.
How to fix it
Upgrade Lua to version 5.2.3 or newer on all affected systems; rebuild or redeploy any applications that statically link older Lua versions; apply vendor patches for OpenSUSE, Ubuntu, Debian, and Mageia packages once available.
How to confirm the fix worked
Confirm Lua version is 5.2.3 or later via lua -v or equivalent; test the original crash condition with a function having many fixed arguments called with few parameters; monitor for absence of segmentation faults in Lua processes.
Typical attack path
- Locate an application or service that embeds a vulnerable Lua 5.1-5.2.2 interpreter
- Identify or reach a code path that calls a Lua function with many fixed arguments
- Supply input or script causing the function to be invoked with far fewer arguments than declared
- Trigger the buffer overflow resulting in process crash
How to detect it
Review application and system logs for Lua process crashes or segmentation faults around the time of suspected exploitation; examine any available core dumps or stack traces referencing ldo.c or vararg handling.
What your security team should do
- Inventory all systems and containers using Lua 5.1 through 5.2.2 and prioritize upgrade within standard change windows
- Block or sanitize untrusted Lua script execution if immediate patching is delayed
- Add Lua version checks to build pipelines and container images to prevent reintroduction of vulnerable versions
The record
Buffer overflow in the vararg functions in ldo.c in Lua 5.1 through 5.2.x before 5.2.3 allows context-dependent attackers to cause a denial of service (crash) via a small number of arguments to a function with a large number of fixed arguments.
Affected packages
| Ecosystem | Package | Introduced | Fixed |
|---|---|---|---|
| Debian:11 | lua5.1 | 0 | 5.1.5-7 |
| Debian:11 | lua5.2 | 0 | 5.2.3-1 |
| Debian:12 | lua5.1 | 0 | 5.1.5-7 |
| Debian:12 | lua5.2 | 0 | 5.2.3-1 |
| Debian:13 | lua5.1 | 0 | 5.1.5-7 |
| Debian:13 | lua5.2 | 0 | 5.2.3-1 |
| Debian:6.0 | lua5.1 | 0 | 5.1.4-5+deb6u1 |
| Debian:7 | lua5.1 | 0 | 5.1.5-4+deb7u1 |
| Debian:7 | lua5.2 | 0 | 5.2.1-3+deb7u1 |
| Mageia:3 | lua | 0 | 5.2.2-1.1.mga3 |
| Mageia:3 | lua5.1 | 0 | 5.1.5-2.2.mga3 |
| Mageia:4 | lua | 0 | 5.2.2-2.1.mga4 |
| Mageia:4 | lua5.1 | 0 | 5.1.5-4.1.mga4 |
| Ubuntu:14.04:LTS | lua5.1 | 0 | 5.1.5-5ubuntu0.1 |
| Ubuntu:14.04:LTS | lua5.2 | 0 | 5.2.3-1 |
| Ubuntu:14.04:LTS | lua50 | 0 | 5.0.3-7 |
| Ubuntu:16.04:LTS | lua50 | 0 | 5.0.3-7 |
| openSUSE:Tumbleweed | moarvm | 0 | 2025.05-1.1 |
Related vulnerabilities
- CVE-2026-112108 A vulnerability was determined in ztxz16 fastllm up to 0.1.8.2. CWE-119
- CVE-2026-112073 A vulnerability was identified in Tencent ncnn up to 44b02dabdcf97499281a4692ebd65bad73dc… CWE-119
- CVE-2026-90831 A vulnerability was detected in GNU Binutils 2.47. CWE-119
- CVE-2026-90804 A vulnerability was detected in GNU Binutils 2.47. CWE-119
- CVE-2026-90803 A security vulnerability has been detected in GNU Binutils 2.47. CWE-119
- CVE-2026-90801 A security flaw has been discovered in GNU Binutils 2.47. CWE-119
- CVE-2026-87933 A vulnerability was found in DaveGamble cJSON up to 1.7.19. CWE-119
- CVE-2026-87931 A vulnerability has been found in Behavioral Technology Group Pavlok Behavioral… CWE-119