CVE-2014-3564
NoneCVSS
—
EPSS
4.3%
Published
Oct 20, 2014
CISA due date
—
Cloudanix analysis
A flaw in older encryption helper software can let attackers crash programs or potentially take control by sending specially formatted data during secure operations.
- Exploitation
- Remote Unauthenticated
- Attacker needs
- None
- Complexity
- Moderate
- Impact
- Remote Code Execution
- Component
- Library
- Class
- Memory Corruption
- Remediation
- Upgrade
- Effort
- Medium
- Patch risk
- Low
What it actually does
Heap-based buffer overflows in status_handler functions within engine-gpgsm.c and engine-uiserver.c allow crafted status lines of varying lengths in specific sequences to corrupt memory, enabling denial of service via crashes and potential arbitrary code execution.
Why it matters to the business
Systems performing cryptographic operations with affected GPGME versions face risk of application crashes and potential compromise, disrupting secure email, file encryption, and key management workflows across Linux distributions and dependent software.
How an attack unfolds
An attacker supplies specially ordered status messages with differing line lengths through a GPGME-using application or direct interface to the gpgsm or uiserver engines, triggering the heap overflow to crash the process or inject and execute arbitrary code.
How to fix it
Upgrade GPGME to version 1.5.1 or later on all affected systems including GNU GPGME installations, Canonical Ubuntu Linux, and Debian Linux distributions; rebuild or update any dependent applications that statically link older versions.
How to confirm the fix worked
Verify installed GPGME version is 1.5.1 or higher via package manager or gpgme-config --version; test affected applications with known-good status inputs to confirm absence of crashes under normal operation.
Typical attack path
- Locate an application or service using a vulnerable GPGME version below 1.5.1
- Craft input containing status_handler data with varying line lengths delivered in a specific sequence
- Trigger the status processing path in engine-gpgsm or engine-uiserver
- Exploit resulting heap corruption to cause denial of service or achieve code execution
How to detect it
Examine application logs for unexpected crashes or segmentation faults in processes linked to GPGME engines; review audit trails around cryptographic operations for anomalous status message patterns or memory error indicators.
What your security team should do
- Immediately inventory all systems for GPGME versions prior to 1.5.1 and prioritize upgrades
- Monitor upstream package repositories for backported fixes on supported distributions
- Review and restrict use of GPGME in exposed services until patches are applied
The record
Multiple heap-based buffer overflows in the status_handler function in (1) engine-gpgsm.c and (2) engine-uiserver.c in GPGME before 1.5.1 allow remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via vectors related to "different line lengths in a specific order."
Affected packages
| Ecosystem | Package | Introduced | Fixed |
|---|---|---|---|
| Debian:11 | gpgme1.0 | 0 | 1.5.1-1 |
| Debian:12 | gpgme1.0 | 0 | 1.5.1-1 |
| Debian:13 | gpgme1.0 | 0 | 1.5.1-1 |
| Debian:6.0 | gpgme1.0 | 0 | 1.2.0-1.2+deb6u1 |
| Debian:7 | gpgme1.0 | 0 | 1.2.0-1.4+deb7u1 |
| Mageia:3 | gpgme | 0 | 1.3.2-2.1.mga3 |
| Mageia:4 | gpgme | 0 | 1.4.3-2.1.mga4 |
| Ubuntu:14.04:LTS | gpgme1.0 | 0 | 1.4.3-0.1ubuntu5.1 |
Related vulnerabilities
- CVE-2026-112108 A vulnerability was determined in ztxz16 fastllm up to 0.1.8.2. CWE-119
- CVE-2026-112073 A vulnerability was identified in Tencent ncnn up to 44b02dabdcf97499281a4692ebd65bad73dc… CWE-119
- CVE-2026-90831 A vulnerability was detected in GNU Binutils 2.47. CWE-119
- CVE-2026-90804 A vulnerability was detected in GNU Binutils 2.47. CWE-119
- CVE-2026-90803 A security vulnerability has been detected in GNU Binutils 2.47. CWE-119
- CVE-2026-90801 A security flaw has been discovered in GNU Binutils 2.47. CWE-119
- CVE-2026-87933 A vulnerability was found in DaveGamble cJSON up to 1.7.19. CWE-119
- CVE-2026-87931 A vulnerability has been found in Behavioral Technology Group Pavlok Behavioral… CWE-119