CVE-2014-1424
NoneCVSS
—
EPSS
1.6%
Published
Nov 24, 2014
CISA due date
—
Cloudanix analysis
A protection mechanism designed to stop programs from performing disallowed actions can be sidestepped, letting attackers do things the system should prevent.
- Exploitation
- Remote Unauthenticated
- Attacker needs
- None
- Complexity
- Low
- Impact
- Privilege Gain
- Component
- Application
- Class
- Authorization Bypass
- Remediation
- Upgrade
- Effort
- Low
- Patch risk
- Low
What it actually does
The flaw permits bypass of AppArmor policy enforcement in apparmor_parser due to a miscompilation error, allowing unauthorized actions that should be restricted.
Why it matters to the business
Attackers can circumvent mandatory access controls on affected systems, increasing risk of unauthorized operations and potential compromise, especially in environments relying on AppArmor for isolation; the Jenkins-core package requires upgrade to 1.606.
How an attack unfolds
An attacker supplies crafted input to the vulnerable apparmor_parser that exploits the miscompilation, resulting in bypassed policy checks and execution of restricted operations.
How to fix it
Upgrade the apparmor package to version 2.8.95~2430-0ubuntu5.1 or later on Ubuntu 14.04 systems; for Jenkins deployments update org.jenkins-ci.main/jenkins-core to version 1.606.
How to confirm the fix worked
Verify the installed package version matches or exceeds the fixed release and test that AppArmor policies are enforced as expected after upgrade.
Typical attack path
- Locate a system running the vulnerable apparmor package or affected Jenkins core version
- Craft input vectors that trigger the miscompilation flaw
- Submit the input to bypass intended AppArmor restrictions
- Perform actions that violate the security policy
How to detect it
Review system and application logs for unexpected policy violations or successful operations that should have been blocked by AppArmor; examine audit trails for anomalous process behavior around the time of policy loading.
What your security team should do
- Apply the listed fixed versions immediately given the public disclosure date and potential for policy bypass
- Audit systems using AppArmor or the affected Jenkins package for correct policy application
- Monitor for any post-upgrade behavioral changes in confined applications
The record
apparmor_parser in the apparmor package before 2.8.95~2430-0ubuntu5.1 in Ubuntu 14.04 allows attackers to bypass AppArmor policies via unspecified vectors, related to a "miscompilation flaw."
Affected packages
| Ecosystem | Package | Introduced | Fixed |
|---|---|---|---|
| Ubuntu:14.04:LTS | apparmor | 0 | 2.8.95~2430-0ubuntu5.1 |
Related vulnerabilities
- CVE-2017-6507 An issue was discovered in AppArmor before 2.12. Also affects apparmor
- CVE-2026-81644 DoS vulnerability in the preview service module. CWE-264
- CVE-2026-49315 DoS vulnerability in the input device module. CWE-264
- CVE-2026-49313 Permission control vulnerability in the app lock module. CWE-264
- CVE-2026-49312 Permission control vulnerability in the window module. CWE-264
- CVE-2026-49310 Permission control vulnerability in the event notification module. CWE-264
- CVE-2026-41987 Permission control vulnerability in the app management module. CWE-264
- CVE-2026-49309 Permission control vulnerability in the Settings module. CWE-264