Cloudanix VulnDB

CVE-2013-7490

Medium · 5.3

CVSS

5.3

EPSS

2.7%

Published

Sep 11, 2020

CISA due date

—

Cloudanix analysis

Monitor only SSVC: Track

A programming library used by many database-connected applications can crash when given too much data in a specific way, and updating the library fixes the problem.

Exploitation
Remote Unauthenticated
Attacker needs
None
Complexity
Low
Impact
Denial Of Service
Component
Library
Class
Memory Corruption
Remediation
Upgrade
Effort
Medium
Patch risk
Low

What it actually does

Supplying an excessive number of arguments to DBI callback methods triggers memory corruption in the Perl DBI module prior to version 1.632.

Why it matters to the business

Applications relying on Perl DBI may experience unexpected crashes or denial of service when processing certain database callback operations, potentially disrupting dependent services and requiring emergency patching across affected systems.

How an attack unfolds

An attacker supplies a large number of arguments to a DBI callback method in a Perl application that uses an unpatched DBI module, causing memory corruption that may result in application instability or limited denial of service.

How to fix it

Upgrade the DBI module to version 1.632 or later. For Ubuntu systems, apply available package updates that include the corrected DBI version.

How to confirm the fix worked

Confirm the installed DBI module version is 1.632 or higher via 'perl -MDBI -e print $DBI::VERSION'. Review application code and dependencies to ensure no older DBI instances remain in use.

Typical attack path

  1. Identify a Perl application using the DBI module for database operations
  2. Locate code paths that invoke DBI methods with callbacks
  3. Craft input that triggers a callback with an excessive number of arguments
  4. Submit the input to cause memory corruption and application impact

How to detect it

Review application and system logs for unexpected Perl process terminations or segmentation faults during database operations. Correlate with code paths that use DBI callbacks.

What your security team should do

  • Immediately inventory all Perl environments and update DBI to 1.632 or newer
  • Prioritize patching systems with external network exposure first
  • Add DBI version checks to dependency scanning and build pipelines
  • Monitor for application crashes correlated with database callback operations

The record

An issue was discovered in the DBI module before 1.632 for Perl. Using many arguments to methods for Callbacks may lead to memory corruption.

Affected packages

Ecosystem Package Introduced Fixed
Debian:11 libdbi-perl 0 1.633-1
Debian:12 libdbi-perl 0 1.633-1
Debian:13 libdbi-perl 0 1.633-1
Debian:14 libdbi-perl 0 1.633-1
SUSE:Enterprise Storage 5 perl-DBI 0 1.628-5.6.1
SUSE:HPE Helion OpenStack 8 perl-DBI 0 1.628-5.6.1
SUSE:Linux Enterprise Point of Sale 11 SP3 perl-DBI 0 1.607-3.6.1
SUSE:Linux Enterprise Server 11 SP4-LTSS perl-DBI 0 1.607-3.6.1
SUSE:Linux Enterprise Server 12 SP2-BCL perl-DBI 0 1.628-5.6.1
SUSE:Linux Enterprise Server 12 SP2-LTSS perl-DBI 0 1.628-5.6.1
SUSE:Linux Enterprise Server 12 SP3-BCL perl-DBI 0 1.628-5.6.1
SUSE:Linux Enterprise Server 12 SP3-LTSS perl-DBI 0 1.628-5.6.1
SUSE:Linux Enterprise Server 12 SP4-LTSS perl-DBI 0 1.628-5.6.1
SUSE:Linux Enterprise Server 12 SP5 perl-DBI 0 1.628-5.6.1
SUSE:Linux Enterprise Server for SAP Applications 12 SP2 perl-DBI 0 1.628-5.6.1
SUSE:Linux Enterprise Server for SAP Applications 12 SP3 perl-DBI 0 1.628-5.6.1
SUSE:Linux Enterprise Server for SAP Applications 12 SP4 perl-DBI 0 1.628-5.6.1
SUSE:Linux Enterprise Server for SAP Applications 12 SP5 perl-DBI 0 1.628-5.6.1
SUSE:OpenStack Cloud 7 perl-DBI 0 1.628-5.6.1
SUSE:OpenStack Cloud 8 perl-DBI 0 1.628-5.6.1
SUSE:OpenStack Cloud 9 perl-DBI 0 1.628-5.6.1
SUSE:OpenStack Cloud Crowbar 8 perl-DBI 0 1.628-5.6.1
SUSE:OpenStack Cloud Crowbar 9 perl-DBI 0 1.628-5.6.1
Ubuntu:14.04:LTS libdbi-perl 0 1.630-1ubuntu0.1~esm4
Ubuntu:18.04:LTS libdbi-perl 0 1.640-1
Ubuntu:Pro:14.04:LTS libdbi-perl 0 1.630-1ubuntu0.1~esm4

Related vulnerabilities