CVE-2013-1884
NoneCVSS
—
EPSS
50.5%
Published
May 2, 2013
CISA due date
—
Cloudanix analysis
A bug in older Subversion servers lets anyone on the network send a specially crafted request that crashes the server and stops people from accessing code repositories.
- Exploitation
- Remote Unauthenticated
- Attacker needs
- None
- Complexity
- Low
- Impact
- Denial Of Service
- Component
- Network Service
- Class
- Memory Corruption
- Remediation
- Upgrade
- Effort
- Medium
- Patch risk
- Low
What it actually does
Remote unauthenticated attacker can trigger a segmentation fault in mod_dav_svn by sending a log REPORT request containing an invalid limit value, causing access to an uninitialized variable and process crash.
Why it matters to the business
Subversion servers become unavailable, halting developer access to version-controlled code and disrupting build pipelines and release processes until the service is restarted.
How an attack unfolds
An attacker locates an exposed Subversion server running mod_dav_svn, crafts a REPORT request for the log operation that supplies an out-of-range limit parameter, and sends it over HTTP; the server dereferences uninitialized memory and terminates.
How to fix it
Upgrade Subversion to a release newer than 1.7.8 that contains the fix for the uninitialized variable handling in mod_dav_svn, or disable the DAV module if Subversion web access is not required.
How to confirm the fix worked
Verify the installed Subversion version is newer than 1.7.8; attempt to reproduce the crash with a test REPORT request containing an invalid limit and confirm the server no longer terminates.
Typical attack path
- Scan for publicly reachable Subversion servers exposing /svn/ paths over HTTP
- Issue a crafted log REPORT request containing an invalid limit value
- Observe server crash and restart behavior to confirm impact
- Repeat requests to maintain denial of service
How to detect it
Review Apache access and error logs for REPORT requests to log paths that contain unusually large or negative limit parameters; correlate with segmentation fault entries mentioning mod_dav_svn or svn processes.
- REPORT.*limit=-
- mod_dav_svn.*segmentation fault
- svn.*uninitialized variable
What your security team should do
- Immediately upgrade all Subversion 1.7.x installations to a patched release
- Restrict network exposure of mod_dav_svn to trusted clients only
- Monitor Apache error logs for segmentation fault entries related to mod_dav_svn
- Consider migrating to a maintained Subversion release branch with ongoing security updates
The record
The mod_dav_svn Apache HTTPD server module in Subversion 1.7.0 through 1.7.8 allows remote attackers to cause a denial of service (segmentation fault and crash) via a log REPORT request with an invalid limit, which triggers an access of an uninitialized variable.
Affected packages
| Ecosystem | Package | Introduced | Fixed |
|---|---|---|---|
| Debian:11 | subversion | 0 | 1.7.9-1 |
| Debian:12 | subversion | 0 | 1.7.9-1 |
| Debian:13 | subversion | 0 | 1.7.9-1 |
| openSUSE:Tumbleweed | subversion | 0 | 1.9.5-1.1 |
Related vulnerabilities
- CVE-2024-46901 Insufficient validation of filenames against control characters in Apache Subversion… Also affects subversion
- CVE-2017-9800 A maliciously constructed svn+ssh:// URL would cause Subversion clients before 1.8.19… Also affects subversion
- CVE-2016-2168 The req_check_access function in the mod_authz_svn module in the httpd server in Apache… Also affects subversion
- CVE-2016-2167 The canonicalize_username function in svnserve/cyrus_auth.c in Apache Subversion before… Also affects subversion
- CVE-2015-5343 Integer overflow in util.c in mod_dav_svn in Apache Subversion 1.7.x, 1.8.x before… Also affects subversion
- CVE-2015-5259 Integer overflow in the read_string function in libsvn_ra_svn/marshal.c in Apache… Also affects subversion
- CVE-2015-0248 The (1) mod_dav_svn and (2) svnserve servers in Subversion 1.6.0 through 1.7.19 and 1.8.0… Also affects subversion
- CVE-2014-3580 The mod_dav_svn Apache HTTPD server module in Apache Subversion 1.x before 1.7.19 and… Also affects subversion