CVE-2011-0992
NoneCVSS
—
EPSS
2.7%
Published
Apr 13, 2011
CISA due date
—
Cloudanix analysis
An outdated browser plugin could let attackers crash it or steal information from users who visit malicious websites, but the issue affects only very old software that is no longer common.
- Exploitation
- Remote Unauthenticated
- Attacker needs
- None
- Complexity
- Moderate
- Impact
- Data Exposure
- Component
- Library
- Class
- Use After Free
- Remediation
- Upgrade
- Effort
- Medium
- Patch risk
- Low
What it actually does
Use-after-free in Mono allows access to member data in a resurrected MonoThread instance, enabling memory corruption that results in plugin crashes or disclosure of sensitive information.
Why it matters to the business
Attackers could disrupt web plugin functionality or expose confidential data in legacy environments still running vulnerable Mono or Moonlight versions, though prevalence is extremely low given the age and lack of known exploitation.
How an attack unfolds
An attacker delivers specially crafted content to a target using the Moonlight plugin, triggering resurrection of a MonoThread object so that freed member data can be read or abused to cause denial of service or leak information.
How to fix it
Upgrade to Moonlight 2.4.1 or later for the 2.x branch and 3.99.3 or later for the 3.x branch; remove or disable the Moonlight plugin where possible since the project is discontinued.
How to confirm the fix worked
Confirm installed Moonlight versions meet or exceed the fixed releases, scan for residual vulnerable binaries, and test crafted inputs that previously triggered the resurrection path.
Typical attack path
- Serve malicious web content or Silverlight-compatible payload to a victim browser running the vulnerable Moonlight plugin
- Trigger MonoThread resurrection through member data manipulation
- Exploit the dangling reference to read freed memory or induce a crash
How to detect it
Review historical browser and web server logs for Moonlight plugin crashes or unusual Silverlight resource requests; search endpoint inventories for any lingering Mono or Moonlight binaries.
What your security team should do
- Immediately inventory and remove any remaining Moonlight installations
- Block legacy plugin execution via browser policies or endpoint controls
- Monitor EPSS and KEV status for any future changes despite the 2011 publication date
The record
Use-after-free vulnerability in Mono, when Moonlight 2.x before 2.4.1 or 3.x before 3.99.3 is used, allows remote attackers to cause a denial of service (plugin crash) or obtain sensitive information via vectors related to member data in a resurrected MonoThread instance.
Affected packages
| Ecosystem | Package | Introduced | Fixed |
|---|---|---|---|
| Ubuntu:14.04:LTS | mono | 0 | 3.2.8+dfsg-4ubuntu1 |
| Ubuntu:14.04:LTS | mono | 0 | 3.2.8+dfsg-4ubuntu1.1 |
Related vulnerabilities
- CVE-2023-26314 The mono package before 6.8.0.105+dfsg-3.3 for Debian allows arbitrary code execution… Also affects mono
- CVE-2026-41983 Null pointer dereference vulnerability in the browser module. Impact: Successful… CWE-399
- CVE-2015-9252 An issue was discovered in QPDF before 7.0.0. CWE-399
- CVE-2012-0881 Apache Xerces2 Java Parser before 2.12.0 allows remote attackers to cause a denial of… CWE-399
- CVE-2015-7944 The RESTful control interface (aka RAPI or ganeti-rapi) in Ganeti before 2.9.7, 2.10.x… CWE-399
- CVE-2015-8855 The semver package before 4.3.2 for Node.js allows attackers to cause a denial of service… CWE-399
- CVE-2015-8858 The uglify-js package before 2.6.0 for Node.js allows attackers to cause a denial of… CWE-399
- CVE-2016-9312 ntpd in NTP before 4.2.8p9, when running on Windows, allows remote attackers to cause a… CWE-399